Opened 4 years ago

Last modified 3 years ago

#10224 assigned defect

After long run test by playmus -l xxx.ogg the loudspeaker has noise.

Reported by: Andy Pei Owned by: Quozl
Priority: low Milestone: Future Release
Component: kernel Version: 1.5-C1
Keywords: Cc:
Blocked By: Blocking: #10229
Deployments affected: Action Needed: reproduce
Verified: no

Description

OS:Sugar
Chipset:Via VX855
OFW:Q3A41
OS:os206
long run test means after 8 or more hours.

Change History (12)

comment:1 Changed 4 years ago by Quozl

  • Action Needed changed from never set to reproduce
  • Owner set to Quozl
  • Status changed from new to assigned

This ticket in os206 factory test fail list, category Audio, item Noise Check: Audio Playing.

I'm trying to reproduce this now, however I don't have the test file used by Andy. Andy can you send that to me? quozl@….

For the moment I'm using one of my own test files.

playmus -l 10224.ogg

comment:2 Changed 4 years ago by Quozl

  • Blocking 10229 added

comment:3 Changed 4 years ago by Quozl

Andy has provided test file. Thanks.

comment:4 Changed 4 years ago by Quozl

Two laptops have been running this test for ten hours without unusual noise from loudspeaker. I'll leave them to run overnight (in a shed), and evaluate tomorrow.

comment:5 Changed 4 years ago by Quozl

  • Milestone changed from Not Triaged to 10.1.2

Unusual noise heard.

comment:6 Changed 4 years ago by Quozl

Reproduced on kernel 2.6.31_xo1.5-20100607.1740.1.olpc.ead3d3e and 2.6.34-rc5-wl.

Reproduced on two XO-1.5 C3 (OLPC D4).

Symptom began after ten hours and before 30 hours of looped playback.

The symptom is cleared by one of these actions:

  • waiting for a while (and the symptom goes away spontaneously and may return),
  • restarting the playmus command,

The symptom is not cleared by any of these actions:

  • removing or reinserting AC adaptor,
  • plugging in headphones and removing them,
  • changing levels in alsamixer.

comment:7 Changed 4 years ago by Quozl

  • Milestone changed from 10.1.2 to 10.1.3

comment:8 Changed 4 years ago by dsd

  • Milestone changed from 11.2.0-M3 to 11.2.0-M4

comment:9 Changed 3 years ago by dsd

  • Component changed from not assigned to kernel
  • Priority changed from normal to low

comment:10 Changed 3 years ago by dsd

  • Keywords retriage? added

I think this should be moved to "Future Release" - its one of those issues that takes a lot of time to fix, hard to commit resources to, and only happens after many hours of audio playback (perhaps not a common use case)

comment:11 Changed 3 years ago by martin.langhoff

  • Milestone changed from 11.2.0-M4 to Future Release

comment:12 Changed 3 years ago by dsd

  • Keywords retriage? removed
Note: See TracTickets for help on using tickets.