Ticket #10235 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

XO 1.5 Audio volume very low

Reported by: tch Owned by: dsaxena
Priority: normal Milestone: 10.1.3
Component: kernel Version:
Keywords: xo-1.5 sound volume Cc: bernie, jasg, martin.langhoff
Action Needed: no action Verified: no
Deployments affected: Paraguay Blocked By:
Blocking:

Description

We have received 150 XO 1.5 that we are currently being used for teachers training. In this training we are using also 30 XO 1.0

We have basically the same build on both machines models, but only the XO 1.5 present this problem.

Any ideas?

Attachments

xo1_5-level-up-4dB.patch (0.5 kB) - added by greenfeld 4 years ago.
olpc-configure sets the volume level on an XO-1.5 but not an XO-1. Take advantage of that and raise the default level.

Change History

  Changed 4 years ago by tch

Test case:

Machines: A = XO 1.5 with os299py (Paraguayan custom build) B = XO 1.0 with os300py (Same build for the XO 1.0)

1. For A and B, increase all the volumes modifiers to maximum. (Sugar volume control, and alsamixer). 2. For A and B, go to Record activity and record the same sound track. 3. The difference should be noticeable, between A (low) and B (normal)

  Changed 4 years ago by tch

The same test case can be applied using Speak Activity.

follow-up: ↓ 4   Changed 4 years ago by Quozl

  • keywords xo-1.5 added; xo 1.5 removed
  • owner set to dsaxena
  • version deleted
  • component changed from not assigned to kernel
  • milestone changed from Not Triaged to 10.1.2

See also #10234 (test for audio record playback sound level differences 8.2.1 vs 10.1.2-beta).

Tests performed using sound level meter at 2mm from speaker, but without a mass production XO-1.5.

OpenFirmware

test /audio
modeltest 1test 2test 3firmware
XO-1 MP80.7 dBA80.8 dBA81.7 dBAQ2E44
XO-1.5 B282.9 dBA81.2 dBA80.2 dBAQ3A40b

Linux and ALSA

speaker-test
modelleft speakerright speakersoftware
XO-1 MP91.8 dBA90.0 dBAos301
XO-1.5 B288.3 dBA86.0 dBAos206

Conclusion

The XO-1.5 is quieter by 3-4 dB when operated via the Linux kernel. This amount of difference would be noticeable. Perhaps we should tweak the levels higher in the kernel.

in reply to: ↑ 3   Changed 4 years ago by tch

Replying to Quozl:

The XO-1.5 is quieter by 3-4 dB when operated via the Linux kernel. This amount of difference would be noticeable. Perhaps we should tweak the levels higher in the kernel.

That would be great :) Thanks

  Changed 4 years ago by Quozl

  • milestone changed from 10.1.2 to 10.1.3

  Changed 4 years ago by erikos

  • next_action changed from reproduce to diagnose

Changed 4 years ago by greenfeld

olpc-configure sets the volume level on an XO-1.5 but not an XO-1. Take advantage of that and raise the default level.

  Changed 4 years ago by greenfeld

Personally I'm not the most fond of this patch, as it reduces the amount of room to go up in volume. I was tempted to use a 3dB rise instead of 4dB, but subjectively I think the difference in A-B testing between an XO-1 and a 1.5 with my chin against the edge of the XOs is greater than 4dB, even though I preferred the way an XO-1.5 sounded with a 3dB or 4dB rise.

Also tested with decent quality headphones, although since they were reasonably sensitive I got my ears blasted at the default level, moreso on an XO-1.

I do not know why we set the master level on boot on an XO-1.5 in olpc-configure but not obviously for a 1.0. The git history for olpc-configure suggests that this has been the case since the 1.5 mixer settings were added.

  Changed 4 years ago by martin.langhoff

  • next_action changed from diagnose to add to build

Sam tells me -10dB for xo-1.5 is the best match so rolled that into olpc-utils-1.0.34 and it's now available from my public_rpms/f11 for the next build.

  Changed 4 years ago by martin.langhoff

  • cc bernie, jasg, martin.langhoff added; bernie jasg removed

  Changed 4 years ago by erikos

  • next_action changed from add to build to test in build

Is in 359.

  Changed 4 years ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

We raise the audio level to -10 dB (78%) in /etc/init.d/olpc-configure -- but after tracing this it looks like someone after us seems to be rounding this up to -9 dB (80% percentagewise).

I'm not going to argue with this for now. In general we are still possibly lower than a XO-1 in quiet things like the Speak activity. But playing the media samples included in the G1G1 Collection makes me wonder if the XO-1.5 can be louder in terms of peak volume in some cases.

The different audio chipsets seem to have different response characteristics.

Filed #10574 to look into seeing if there is a better fix.

  Changed 4 years ago by Quozl

(I still think the best solution is to fix the kernel driver. When the driver was adopted, a quick choice was made to set the levels, and at the time this choice seemed reasonable. This ticket was raised when the choice was found to be wrong. You've since compensated for it by raising the default value for a mixer control. It is an odd place to put a fix. My tests with OpenFirmware showed no significant difference. Have you confirmed those tests?)

Note: See TracTickets for help on using tickets.