Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10245 closed defect (wontfix)

os301 - keyboard does not change screen brightness

Reported by: mikus Owned by: pgf
Priority: normal Milestone: 10.1.2
Component: olpc-kbdshim Version: Development source as of this date
Keywords: olpc-kbdshim-13 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Booted os301. Started Terminal. Pressed XO-1 keyboard "small starburst" key multiple times. Screen did not get dimmer.

Attachments (1)

logs.SHF8080225D.2010-07-21.07-25-25.tar.bz2 (270.8 KB) - added by mikus 4 years ago.
os301 - system dump after failing to dim the screen from the XO-1 keyboard

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by mikus

os301 - system dump after failing to dim the screen from the XO-1 keyboard

comment:1 Changed 4 years ago by Quozl

  • Action Needed changed from never set to diagnose
  • Component changed from not assigned to olpc-kbdshim
  • Milestone changed from Not Triaged to 10.1.2
  • Owner set to pgf

Tested, unable to reproduce on os301 fresh install.

Analyzed logs, olpc-kdbshim-hal process is correctly present, shell.log contains errors "Cannot get display brightness" and "Cannot set display brightness" which should not appear unless the key events are being passed to Sugar.

Looking at rpm.out, your system has olpc-kbdshim-13-1.fc11.i586 but mine has olpc-kbdshim-12-1.fc11.i586. It looks like you may have found a regression in -13.

comment:2 Changed 4 years ago by pgf

  • Resolution set to wontfix
  • Status changed from new to closed

nicely diagnosed, quozl, thank you.

indeed, olpc-kbdshim-13 moves the bindings for brightness and volume from F9-F12 to the evdev BRIGHTNESSDOWN/UP and VOLUMEDOWN/UP keys, to coincide with the new olpc-utils package which will be coming soon to a repository near you. this change is a result of the outcome of #100213 -- if the Fn-Fkeys are to produce F9-F12 and kbdshim must let those through, then kbdshim must bind to something other than those values, breaking backward compatibility.

the silver lining is that kbdshim now allows optionally binding to either F9-F12 or the evdev keys, or both, or neither.

  • echo F9 or f9 into /var/run/olpc-kbdshim_commands to enable or disable binding to F9-F12.
  • echo FBV or fbv into the same place to enable or disable bind to the evdev keys.

so mikus can restore function to his keys with:

echo F9 > /var/run/olpc-kbdshim_commands

when the new olpc-utils is available, maybe i should do a new kbdshim that depends on it.

comment:3 Changed 4 years ago by Quozl

  • Action Needed changed from diagnose to no action
  • Version changed from Development build as of this date to Development source as of this date

Wasn't a build regression, changing milestone to development source.

comment:4 Changed 4 years ago by pgf

new olpc-utils (1.0.26), and new olpc-kbdshim (14) which depends on it, have been included in os302.

closing.

comment:5 Changed 4 years ago by Quozl

  • Keywords olpc-kbdshim-13 added
Note: See TracTickets for help on using tickets.