Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#10272 closed defect (duplicate)

turning on radio takes too long before favourite wireless connection is established

Reported by: Quozl Owned by:
Priority: normal Milestone: 10.1.3
Component: not assigned Version: Development build as of this date
Keywords: os304 Cc: sascha_silbe, sridhar
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

  • associate with a wireless access point (which marks it as a favourite), and verify another XO is present in Neighbourhood view,
  • make the frame visible,
  • in My Settings, Power, turn off Automatic power management, (for the purposes of this test),
  • in My Settings, Network, turn off Radio,
  • wait five seconds,
  • turn on Radio, and begin timing,
  • switch back to the Neighbourhood view,
  • wait until networking has been restored, the frame shows associated state, and the other XO has reappeared, then stop timing.

Turning on radio takes 30-35 seconds. This is too long. It can be done manually in four seconds if NetworkManager is disabled:

rfkill unblock wifi && \
sleep 2 && \
iwconfig eth0 essid xo && \
sleep 2 && \
dhclient eth0

Change History (7)

comment:1 Changed 4 years ago by pgf

this might be a dup of #9854. if not a dup, it's surely related.

comment:2 Changed 4 years ago by Quozl

yes, it may be, and thus might be an easier reproducer to work from since it avoids suspend or powerd.

comment:3 Changed 4 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:4 Changed 4 years ago by Quozl

  • Milestone changed from Not Triaged to 10.1.3

comment:5 Changed 4 years ago by martin.langhoff

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9854

comment:6 Changed 3 years ago by sridhar

  • Cc sridhar added

comment:7 Changed 3 years ago by Quozl

  • Action Needed changed from diagnose to no action

Tested, 11.2.0 build os22 takes six to seven seconds.

Note: See TracTickets for help on using tickets.