Opened 4 years ago

Closed 4 years ago

#10278 closed task (worksforme)

test olpc-update 8.2.1 to 10.1.2

Reported by: Quozl Owned by: Quozl
Priority: normal Milestone: 10.1.3
Component: upgrade utility Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description


Change History (11)

comment:1 Changed 4 years ago by Quozl

  • Action Needed changed from never set to test in build
  • Component changed from not assigned to upgrade utility
  • Milestone changed from Not Triaged to 10.1.2
  • Status changed from new to assigned
  • Version not specified deleted

Test plan:

  • install 8.2.1 os802 bare of activities,
  • boot,
  • associate with access point,
  • install Terminal, Chat, Record, and Write using software update,
  • record eth0 received byte count, and wall clock time,
  • olpc-update 10.1.2_xo1-850 (and verify command completes without error),
  • record eth0 received byte count, and wall clock time,
  • restart,
  • test old activities briefly against new build,
  • perform software update of the selected activities,
  • test new activities briefly against new build.

comment:2 Changed 4 years ago by Quozl

Successful upgrade:

  • eth0 byte count 362545702 (345.7 MiB),
  • duration 309 minutes (five hours) on remote 3G (avg 400ms ping to laptop.org).

Non-upgraded activities from os802 passed usage test on os850:

  • Calculate-30
  • Chat-48 (collaboration against an os850 XO-1.5 build)
  • Moon-11
  • Read-56 (activated from journal view of USB stick with a PDF file present)
  • Ruler-3
  • Record-64
  • Speak-16
  • Terminal-18
  • Write-60

Failed test:

  • Browse-102 (import of hulahop.webview failed)

Side-effects:

  • favourite access point data lost, (the file name changed from 0.82 networks.cfg to 0.84 connections.cfg),
  • no /root directory for $HOME of user root on console,

comment:3 Changed 4 years ago by dsd

Ah, I had missed that the /root vs /home/root thing was not applied in pilgrim until post-8.2.
So we need to fix #6700 in 10.1 to fix that final point.

comment:5 Changed 4 years ago by Quozl

XO-1 os850 to os851 74 minutes 22.9 MiB, done within GNOME Terminal.

comment:6 Changed 4 years ago by Quozl

XO-1.5 os850 to os851 took 104 minutes 32.9 MiB.

comment:7 Changed 4 years ago by Quozl

Test with insufficient space.

Test design: SJ said with 358MB free it failed, therefore fill jffs2 with compressed data until less than 358MB is free and retry update.

until [ $(df /|awk '/mtd0/ {print $4}') -le 357000 ]; do
  cp /boot/vmlinuz fs.$(date +%s.%N);
  df /;
done

Does indeed fail during olpc-update with No space left on device. Removed files gradually until it worked. About 300Mb of space had been consumed by the above files at the point it worked.

comment:8 Changed 4 years ago by Quozl

(os802.img has 767 MB free after install, it completed with 300 MB of the 767 MB in use, therefore 467 MB was required by the upgrade).

comment:9 Changed 4 years ago by Quozl

Retesting with gg-802-1.img 33f096d4653c4199e85b61586af09476.

Free space after install is 545 MB.

Software update offered 75.6 MB of downloads. Terminal was not offered.

After olpc-update to os851 there was 122 MB free space.

This reduces to 114 MB after reboot but before Software update.

Software update offers 289.4 MB of downloads. This is greater than the free space, but the downloads are installed as soon as they occur.

After update to all but Wikipedia, free space was 56 MB. Wikipedia (97 MB) could not be downloaded and installed, because there was insufficient free space.

comment:10 Changed 4 years ago by Quozl

  • Milestone changed from 10.1.2 to 10.1.3

comment:11 Changed 4 years ago by Quozl

  • Action Needed changed from test in build to no action
  • Resolution set to worksforme
  • Status changed from assigned to closed

No further testing of this feature seems required at present.

Note: See TracTickets for help on using tickets.