Opened 4 years ago

Closed 4 years ago

#10283 closed defect (fixed)

cups does not show documentation on web browser

Reported by: eowens2 Owned by:
Priority: low Milestone: 10.1.2
Component: fedora Version: Development build as of this date
Keywords: os851 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description (last modified by Quozl)

In OS300 to which cups-i586 has been added, cups started with

/etc/init.d/cups start

when one enters "localhost:631/" in browser, the error "404 - Not Found" is generated.

Looking at /var/log/cups/error_log one sees

Unable to set ACLs on root certificate '/var/run/cups/certs/0'

Am I doing something wrong, or is this a bug?

Change History (7)

comment:1 Changed 4 years ago by Quozl

  • Action Needed changed from never set to communicate
  • Description modified (diff)
  • Summary changed from In OS300 to which cups-i586 has been added, cups started with "/etc/init.d/cups start", when one enters "localhost:631/" in browser, the error "404 - Not Found" is generated. Looking at /var/log/cups/error_log one sees "Unable to set ACLs on root certificate '/var/run/cups/certs/0'". Am I doing something wrong, or is this a bug? to cups does not start

Moved problem description from summary field to description field and reformatted.

We don't ship cups. We don't do anything to intentionally disable cups. Have you verified this works for you on a standard Fedora 11 system?

os300 is somewhat old now, please try os850.

comment:2 Changed 4 years ago by kevix

on an xo-1.5 C2 with os204, I had the same symptoms. But a friend pointed out that localhost:631/admin (and all other tabs) worked with the exception of /. I was able to use 'sudo system-config-printer' to configure a new printer. (my comment seems to be a duplicate of #10283)

comment:3 in reply to: ↑ description Changed 4 years ago by eowens2

  • Resolution set to fixed
  • Status changed from new to closed

Replying to eowens2:

In OS300 to which cups-i586 has been added, cups started with

/etc/init.d/cups start

when one enters "localhost:631/" in browser, the error "404 - Not Found" is generated.

Looking at /var/log/cups/error_log one sees

Unable to set ACLs on root certificate '/var/run/cups/certs/0'

Am I doing something wrong, or is this a bug?

I am now running os850, and the same error occurs trying to access http://localhost:631/. However the above comment by kevix noted, and "http://localhost:631/admin" does well as a workaround with cups-1.4.2-26.fc11.i586 to enable printer configuration and printing.

As far as I am concerned the problem is resolved.

comment:4 Changed 4 years ago by Quozl

  • Action Needed changed from communicate to diagnose
  • Component changed from not assigned to fedora
  • Keywords os851 added
  • Milestone changed from Not Triaged to 10.1.3
  • Priority changed from normal to low
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from not specified to Development build as of this date

Eddie, you said elsewhere that you thought I meant that the problem lies in CUPS, not the XO. No, that's not really what I meant. When I said "We don't ship cups", that was shorthand for: "CUPS and the cups package isn't in the scope of work for the release of this operating system to laptop deployments".

Regarding where the problem lies:

  • the problem might lie with CUPS, in which case it can be reported to Fedora or the CUPS upstream project for them to investigate,
  • the problem might lie with something we've done to the operating system that prevents CUPS from working normally, in which case we're obliged to figure out what we've done so that we can ensure that those deployments that rely on CUPS can make it work.

I'm inclined toward the latter, but since we don't ship CUPS I'm obliged to not spend too much time on it in the face of more important problems. However, I can report the following:

  • the underlying cause of the symptom is a missing file /usr/share/cups/www/index.html
  • this file is present on unmodified Fedora 11 with cups package installed during operating system installation,
  • this file is absent on os851 with cups package installed after operating system installation.

My guess is that one of the extreme customisations we have done to reduce the size of our operating system build has removed a package which is used during post-install scripts of the cups package.

We don't know the impact of this yet, but we'll keep it open in case there might be other packages affected, or in case a laptop deployment is affected.

You can workaround the symptom by obtaining an index.html file from a Fedora 11 system.

comment:5 Changed 4 years ago by Quozl

  • the missing file is included in the RPM package file cups-1.4.2-26.fc11.i586.rpm

comment:6 Changed 4 years ago by Quozl

  • Action Needed changed from diagnose to qa signoff
  • Summary changed from cups does not start to cups does not show documentation on web browser

Cause further identified.

Our operating system builder script olpc-os-builder.git/osbuilder.py emits a directive to kickstart/imgcreate:

%packages --excludedocs

As a result, the installed operating system build on an XO contains a file /etc/rpm/macros.imgcreate with a line:

%_excludedocs 1

As a result, the installation of the cups-1.4.2-26.fc11.i586.rpm avoids unpacking all files marked as documentation. The missing file index.html is marked as documentation, and so it is excluded. CUPS will run correctly without it, but without providing documentation to the user via web browser, hence the 404 error.

In order to keep the operating system images small, we should continue to exclude documentation files, so we won't be fixing this. I'll add it to the release notes as a known problem.

An alternate workaround was tested. Edit the file /etc/rpm/macros.imgcreate, comment out or remove the %_excludedocs macro, and then install cups. As a result the index.html file is placed properly, and the web browser is able to see the documentation.

comment:7 Changed 4 years ago by Quozl

  • Action Needed changed from qa signoff to no action
  • Milestone changed from 10.1.3 to 10.1.2
  • Resolution set to fixed
  • Status changed from reopened to closed

Added to release notes.

Note: See TracTickets for help on using tickets.