Ticket #10307 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

Boot has failed - dracut: FATAL : Don't know how to handle 'root=mtd0'

Reported by: Nuke Owned by: Quozl
Priority: normal Milestone: 10.1.3
Component: not assigned Version: Development build as of this date
Keywords: dracut boot fail q2e44 Cc:
Action Needed: diagnose Verified: no
Deployments affected: Blocked By:
Blocking:

Description (last modified by Quozl) (diff)

XO-1 with q2e44. Updated to 10.1.2 yesterday.

SD card has Ubuntu 8.04 LTS (Teapot version updated) installed. Usually XO boots directly to Ubuntu. Wanted to make backup of SD card.

I understand that if you boot and hold down "O" game pad controller button, the XO-1 should boot to Sugar. The boot process hangs.

Errors msg:

dracut: FATAL : Don't know how to handle 'root=mtd0'
dracut: Refusing to continue
Signal caught!
Boot has failed, sleeping forever.

Change History

Changed 4 years ago by Quozl

  • status changed from new to assigned
  • next_action changed from never set to diagnose
  • description modified (diff)
  • keywords q2e44 added
  • version changed from 1.0 Hardware to Development build as of this date
  • milestone changed from 10.1.2 to 10.1.3
  • owner set to Quozl

Please remove the SD card from the slot and confirm for us whether the XO-1 boots to Sugar with or without the "O" game pad key.

(It seems likely that our dracut configuration might not properly handle the existence of an SD card with Ubuntu 8.04 on it.)

Also, could you please identify the development build you have installed. 10.1.2 is not yet released, so I can't tell from what you said.

Changed 4 years ago by Nuke

I can confirm that with no SD card, the boot to both Sugar and Fedora works properly.

I'm not sure how to tell directly from XO what the build number is. However, I used the instructions from  http://wiki.laptop.org/go/Release_notes/10.1.2#XO-1 and downloaded and used the os851.img and os851.img.fs.zip files to do the install.

Changed 4 years ago by Nuke

Ah. Found it.

Build: 851 Sugar: 0.84.16 Firmware: Q2E44 Wireless Firmware: 5.110.22.p23

PS - There is no "Software Update" in My Settings anymore. Why?

Changed 4 years ago by dsd

This will be an incompatibility with the olpc.fth on your SD card (which is somehow programmed to attempt to boot the NAND if circle is pressed) and the new initramfs, which requires an empty root= parameter because dracut doesn't (yet) understand direct access to mtd devices.

won't be fixed for 10.1.2, you should tweak your SD card if it matters.

I think this ticket can be closed...

Changed 4 years ago by Quozl

  • status changed from assigned to closed
  • resolution set to wontfix

I agree, can be closed. Cause is the SD card which we don't control.

Re: the PS. Software update should be present, and is for me, make sure you scroll the My Settings window content to the left. You can do that with the scroll bar, with right arrow key modified by the grab key, or with grab key and touchpad lateral single finger left-to-right drag.

Changed 4 years ago by Nuke

Sure thing, I'm new at this.

Any idea why it does work properly with the same SD card using image gg-802-1.img which I think is v8.2.1?

Changed 4 years ago by Quozl

Yes, gg-802-1.img aka 8.2.1 had different requirements for kernel command line. The command line was included in /boot/olpc.fth in the gg-802-1.img build.

When 10.1.2 comes along, it will have requirements for kernel command line that are included in /boot/olpc.fth currently in the os851.img build.

By copying the 8.2.1 olpc.fth without reference to the 10.1.2 olpc.fth, your SD card has failed to remain compatible with 10.1.2.

Changed 4 years ago by Quozl

Note: See TracTickets for help on using tickets.