Ticket #10411 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

holding rotate button while powering up disables laptop until power removed

Reported by: Quozl Owned by: rsmith
Priority: low Milestone: Not Triaged
Component: embedded controller Version: not specified
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

XO-1.5, powered off, with a battery ... if you hold down the rotate button, and then press the power button, the laptop does not boot. Also, it requires removal of the battery before it will boot again.

Change History

Changed 4 years ago by Quozl

Reproduced on Q3A54.

  • power off laptop,
  • press and hold rotate button,
  • power on laptop.

Symptom is panel backlight off, screen off, no serial port output from OpenFirmware, can be powered off by holding the power button down, but no response to any other input.

Symptom is cleared by removing battery and external power.

Symptom occurs with battery, with external power, or both.

Does not occur if the rotate button is pressed more than about half a second after the power button is pressed. In that circumstance, OpenFirmware starts, the screen backlight is on, and the user is prompted to release the rotate button.

May occur if the rotate button is pressed immediately after the power button is pressed.

Changed 4 years ago by Quozl

When the symptom is present, holding the power button down for four seconds causes the power LED to blink and then go out. This does not clear the symptom, however.

Changed 4 years ago by Quozl

Affected serial numbers in my XO-1.5 stock

SHC005007AD
SHC005008AC
SHC016013D9
SHC0160140A
SHC937010AA
SHC93701192
SHC93701699
SHC9500001C
SHC9500002A

None not affected.

Changed 4 years ago by Quozl

Log supplied by Luna.

!!!REBOOT!!!
20100920-
Ver:1.9.37
WDT:0
00,OEMPwrInit
Setting PlatformID d3
Checking Platform ID
Gen 1.5 rev C1
0:PwrInit2
0:Force power off
0:pre MSD Off
0:post MSD Off
Chg Off
KBC Debug=0
AC In
52:SCI:0040
2807:Dbounce
2968:PwrButPress assert
2978:PwrUP
3099:Board ON
3102:KBDpwr
3132:RSM_RST
3205:KBCID
3207:Got 0xAA
3210:f5->
3213:ack
3216:f2->
3219:ack
3224:EnE KBC: 0xf7->
ack
3231:f4->
3234:ack
 PS2IF: 0
3237:KBCID done
3247:PWR_BUT strobe
3260:MAIN_ON

3284:-10,
3295:-19,
3381:-22,
3806:PwrUp Done
3821:-2F,
3918:-40,
3920:-45,
3923:-47,
3927:-48,
3930:-4C,
3936:-4E,
3956:-50,
3960:-51,
3974:-53,
5011:Battery Poll
10869:Hardware off
10880:pre MSD Off
13956:post MSD Off
13959:system off
13962:PwrUP
14084:ARTEC Mode Enabled. No FWH response!
14090:Board ON
14093:KBDpwr
14123:RSM_RST
14196:KBCID
14198:Got 0xAA
14202:f5->
14204:ack
14207:f2->
14210:ack
14216:EnE KBC: 0xf7->
ack
14223:f4->
14225:ack
 PS2IF: 0
14229:KBCID done
14241:PWR_BUT strobe
14254:MAIN_ON

14284:PwrUp Done
15493:Battery Poll

Changed 4 years ago by Quozl

Also occurs on Q3A34, EC version 1.9.24.

Changed 4 years ago by wad

  • owner set to rsmith
  • priority changed from normal to low
  • component changed from not assigned to embedded controller

This is a feature, not a bug.

We finally got enough of Richard's attention to verify that when you hold down the rotate key while booting the laptop, the EC enters a special debug mode in which it does not respond to the LPC bus.

The hardware is powering up fine, but no code may be fetched from the SPI boot ROM.

This is confirmed by the EC serial output (see above). At time 14084 it prints: "ARTEC Mode Enabled. No FWH (Firmware Hub) response"

Changed 4 years ago by Quozl

Noted feature status. Added to release notes as will not power up if rotate key held down.

Changed 4 years ago by Quozl

IRC discussions at the time indicated this feature may be removed in a future release of the EC firmware.

(For OpenFirmware dual-boot support, we've chosen to avoid the rotate key. patch)

Changed 4 years ago by rsmith

  • next_action changed from never set to test in build

ARTEC mode disabled in current release.

Changed 4 years ago by Quozl

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

Tested Q3A61 aka EC 2.0.1, problem is fixed, closing.

Note: See TracTickets for help on using tickets.