Opened 4 years ago

Closed 4 years ago

#10455 closed defect (fixed)

libertas-related slab corruption

Reported by: dsd Owned by: dsd
Priority: low Milestone: 11.2.0-M1
Component: kernel Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

When unloading the libertas_sdio module or doing suspend/resume, slab corruption is consistently encountered.

We are using the SLAB allocator. SLUB has better diagnostics in these cases, but when switching to SLUB, no corruption is detected.

kmemcheck doesn't find anything.

Seems to be a 2.6.35 regression, did not happen in 2.6.31.

Change History (5)

comment:2 Changed 4 years ago by dsd

  • Priority changed from normal to low

reverted in olpc-2.6.35 branch, leave ticket open for upstream fix

comment:3 Changed 4 years ago by dsd

  • Action Needed changed from never set to communicate

comment:4 Changed 4 years ago by dsd

  • Action Needed changed from communicate to test in build

merged upstream

test in f14-3

comment:5 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

confirmed working in f14-4 on XO-1.5

Note: See TracTickets for help on using tickets.