Opened 4 years ago

Closed 4 years ago

#10523 closed defect (fixed)

Need to expand size of version field

Reported by: greenfeld Owned by: erikos
Priority: normal Milestone: 10.1.3
Component: sugar Version: Development source as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

I edited Paint-29's activity.info file so the version number was "29-Peru". In Sugar's Activity table/list view I saw the version was "29-..." until I hovered my mouse over the version number.

We should expand the size of this field in the table; there is plenty of room to go before we show the date of activity creation, and I don't know of any fields in-between (does anyone?).

If expanded, this needs to be tested with both left-to-right and right-to-left languages.

Tested in 10.1.3 os 355.

Change History (5)

comment:1 Changed 4 years ago by greenfeld

  • Action Needed changed from never set to diagnose

comment:2 Changed 4 years ago by erikos

  • Milestone changed from Not Triaged to 10.1.3

A regression, let's try to fix it.

comment:3 Changed 4 years ago by erikos

  • Action Needed changed from diagnose to add to build

Looks like this should cover most of the cases.

diff --git a/src/jarabe/desktop/activitieslist.py b/src/jarabe/desktop/activitieslist.py
index a8332f0..90b0752 100644
--- a/src/jarabe/desktop/activitieslist.py
+++ b/src/jarabe/desktop/activitieslist.py
@@ -203,7 +203,7 @@ class ActivityEntry(hippo.CanvasBox, hippo.CanvasItem):
     __gtype_name__ = 'SugarActivityEntry'
 
     _TITLE_COL_WIDTH   = style.GRID_CELL_SIZE * 3
-    _VERSION_COL_WIDTH = style.GRID_CELL_SIZE * 1
+    _VERSION_COL_WIDTH = style.GRID_CELL_SIZE * 3
     _DATE_COL_WIDTH    = style.GRID_CELL_SIZE * 5
 
     def __init__(self, activity_info):

comment:4 Changed 4 years ago by erikos

  • Action Needed changed from add to build to test in build

The size has been increased a bit ('35-Argentina' does fit at least).

comment:5 Changed 4 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Verified that we had enough space for "87.1-Argentina" in 10.1.3 os360's Activity list view in English, French, Spanish, and Arabic.

Note: See TracTickets for help on using tickets.