Opened 4 years ago

Closed 4 years ago

#10565 closed defect (fixed)

DPI grows by approx 1px on each rotation

Reported by: martin.langhoff Owned by: jnettlet
Priority: normal Milestone: 11.2.0-M3
Component: x window system Version: Development build as of this date
Keywords: Cc: dsd, erikos
Blocked By: Blocking: #10453
Deployments affected: Action Needed: code
Verified: no

Description

Repro

  • Using 10.1.3 series (build 360 tested)
  • open Terminal.xo (or Gnome Terminal) - run xdpyinfo | grep resolution
  • Press the rotate button a few times
  • Run xdpyinfo | grep resolution again
  • After 8 rotations, open Browse.xo, pages will render with large fonts

This stems from a buglet in the xserver/xrandr DPI calculations when rotation happens. It gets exposed once #10453 (which describes a different DPI issue) is fixed.

Change History (2)

comment:1 Changed 4 years ago by martin.langhoff

  • Blocking 10453 added

comment:2 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

seems to be fixed in newer X versions - can't reproduce on 11.2.0-7 on XO-1

Note: See TracTickets for help on using tickets.