Opened 4 years ago

Closed 4 years ago

#10597 closed defect (fixed)

2011 rollover on old firmware causes loss of keyboard/mouse interrupts

Reported by: Quozl Owned by:
Priority: normal Milestone: Future Release
Component: not assigned Version: not specified
Keywords: y2k+11 Cc: holt
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

Symptom: XO-1 keyboard and touchpad do not respond in Sugar.

Triggering firmware versions: Q2D07, Q2D08 (related but not triggering operating system versions: os650, os653, os656.)

Triggering condition: real-time clock year set to or rollover to 2011 and later, then power up and boot.

Diagnosis: /proc/interrupts shows zero interrupts arriving for IRQ 1 (keyboard), and no mapping of IRQ 12 (touchpad). Adding i8042.debug=1 shows IRQ 12 did not arrive when the driver requested
it to. None of the changes between Q2D08 and Q2D09 appear likely to
have fixed it intentionally, but fixed it is.

Condition clearing actions:

  • upgrade firmware to Q2D09 or later then remove battery and external power, then boot,
  • upgrade firmware to signed Q2D14 then remove battery and external power, then boot, (tested by Adam Holt),
  • remove battery, remove external power, disassemble, temporarily disconnect real-time clock battery (high risk of causing damage), reassemble, set real-time clock year to 2010 then boot.

Change History (3)

comment:1 Changed 4 years ago by holt

  • Cc holt added

comment:2 Changed 4 years ago by dsd

  • Milestone changed from Not Triaged to Future Release
  • Summary changed from XO-1 keyboard and touchpad do not respond in Sugar to 2011 rollover on old firmware causes loss of keyboard/mouse interrupts

comment:3 Changed 4 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed

Is fixed in current release, we don't understand the cause, and we don't have the resources to figure out why it happened.

Note: See TracTickets for help on using tickets.