Ticket #10606 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Virtual change sets XO-1.5 default resolution to 1200x1200

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 11.2.0-M2
Component: x window system Version: not specified
Keywords: Cc:
Action Needed: test in build Verified: no
Deployments affected: Blocked By:
Blocking:

Description

From #10453, the following change causes X to start up with resolution 1200x1200 on F14:

http://dev.laptop.org/git/projects/olpc-utils/commit/?id=100f32edc1384bbd5af678457a9fe697880e9014

In other words, the whole screen scrolls up and down as you move the mouse to the upper and lower parts of the screen.

Running "xrandr" shows a list of resolutions far different from the one in the X config, and shows that it is running at 1200x1200. "xrandr -s 1200x900" restores normal behaviour.

Change History

  Changed 4 years ago by dsd

tested only on XO-1.5, XO-1 may or may not be affected

  Changed 4 years ago by dsd

  • next_action changed from diagnose to package
  • summary changed from Virtual change sets default resolution to 1200x1200 to Virtual change sets XO-1.5 default resolution to 1200x1200

Jon says this is because there is no RandR-1.2 compatible openchrome driver that works on F14, which is a requirement for the Virtual change, and that XO-1 should be unaffected.

reverted this change for now (for XO-1.5 only)

  Changed 4 years ago by dsd

  • milestone changed from 11.2.0-M1 to 11.2.0-M2

  Changed 4 years ago by greenfeld

This issue is present in os5 on the XO-1.5 platform, even though the reversion was done 5 days ago.

I wouldn't know why though.

  Changed 4 years ago by dsd

it hasn't been packaged (see action needed field)

follow-up: ↓ 8   Changed 4 years ago by mavrothal

Removing "Virtual 1200 1200" from xorg.conf blocks screen rotation ( #9359 )

  Changed 4 years ago by mavrothal

ooops this should be #9350

in reply to: ↑ 6   Changed 4 years ago by mavrothal

Replying to mavrothal:

Removing "Virtual 1200 1200" from xorg.conf blocks screen rotation ( #9359 )

Actually, screen rotation is broken even with "Virtual 1200 1200" (#10625)

  Changed 4 years ago by dsd

  • next_action changed from package to add to build

  Changed 4 years ago by dsd

  • next_action changed from add to build to test in build

test in 11.2.0-6

  Changed 4 years ago by dsd

  • status changed from new to closed
  • resolution set to fixed

confirmed working on 11.2.0-7, everything fits on the screen

Note: See TracTickets for help on using tickets.