Opened 4 years ago

Closed 3 years ago

#10668 closed defect (fixed)

XO-1.75 A2 low or critical battery indicator persists when power off

Reported by: Quozl Owned by: rsmith
Priority: low Milestone: 1.75-firmware
Component: embedded controller Version: 1.75-A2
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

With a low or critical battery, the battery indicator continues to indicate (orange/red flashing or constant red) despite the laptop being powered off.

Change History (7)

comment:1 Changed 3 years ago by Quozl

  • Action Needed changed from reproduce to diagnose

Reproduced on XO-1.75 A2 with Q4A13f and 0.0.8, and 0.0.9. Put a battery in, allow to discharge, after low voltage shutdown observe battery LED indicator on.

comment:2 Changed 3 years ago by pgf

is this new behavior? i'm pretty sure the same thing happens on the x86 laptops as well. (which doesn't make it correct.)

comment:3 Changed 3 years ago by Quozl

not recently tested ... on the x86 laptops, the red LED only appears when a game key is touched, and eventually goes away ... but on ARM the red LED just appears and stays.

comment:4 follow-up: Changed 3 years ago by Quozl

Also seen Q4B06 on XO-1.75 B1 per #11105.

comment:5 in reply to: ↑ 4 Changed 3 years ago by rsmith

Replying to Quozl:

Also seen Q4B06 on XO-1.75 B1 per #11105.

This is fixed in EC head. Will show up in next EC release.

comment:6 Changed 3 years ago by Quozl

  • Action Needed changed from diagnose to test in build

Not seen since the fix made it into Q4B07, needs a test.

comment:7 Changed 3 years ago by Quozl

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Tested in Q4B08 with EC 0.2.03, on two laptops, no longer occurs. The lowest battery voltage displayed by watch-battery was 5.49V, then the EC did automatic power off. Closing.

Note: See TracTickets for help on using tickets.