Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#10675 closed defect (fixed)

Shared activity users do not get clustered around activities they are collaborating in

Reported by: greenfeld Owned by: erikos
Priority: high Milestone: 11.2.0-M4
Component: sugar Version: Development build as of this date
Keywords: collaboration, tested Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

When an activity is shared in 11.2.0 os7, the shared activity's users do not get clustered around the activity they are collaborating with in the Sugar network view.

Instead, the activity just appears at a seemingly random point onscreen in a location independent of any of its participants.

Attachments (4)

sharer.png (19.8 KB) - added by erikos 3 years ago.
A is the person that shared a chat activity
B.png (11.5 KB) - added by erikos 3 years ago.
This is the nb view of A, B is in the activity, C is not in the activity yet
C.png (13.0 KB) - added by erikos 3 years ago.
This is the nb view of C (red), B is in the activity, A is not in the activity yet
B_joined.png (12.0 KB) - added by erikos 3 years ago.
This is the nb view of B, everyone is in the activity A and C are drawn around the activity, the owner here A is always drawn in the middle and does not change position when in a shared activity

Download all attachments as: .zip

Change History (18)

comment:1 Changed 4 years ago by greenfeld

  • Version changed from not specified to Development source as of this date

Interestingly, when I had a 10.1.3 laptop start up a shared Chat session on the same channel, the 11.2.0 development XOs were able to show that the older XO had started the chat session, and were able to connect to chat with the older Chat build on the older OS.

They did not however show themselves as participants in the Chat session when I checked.

comment:2 Changed 4 years ago by erikos

  • Milestone changed from Not Triaged to 11.2.0-M4
  • Version changed from Development source as of this date to Development build as of this date

comment:3 Changed 4 years ago by erikos

  • Keywords collaboration added

comment:4 Changed 4 years ago by erikos

I have seen this with the following Salut (link local) setup:

  • two machines running 11.2.0 (A, B), one is running 10.1.3 (C)
  • C is sharing an activity
  • A and B are joining
  • on the neighborhood view of (A,B) only C is grouped around the activity
  • on the neighborhood view of C no buddy is grouped around the activity

comment:5 Changed 4 years ago by erikos

  • Priority changed from normal to high

comment:6 Changed 3 years ago by erikos

  • Action Needed changed from diagnose to review

comment:7 Changed 3 years ago by erikos

When testing, please be aware that #10674 is not fixed yet.

Changed 3 years ago by erikos

A is the person that shared a chat activity

Changed 3 years ago by erikos

This is the nb view of A, B is in the activity, C is not in the activity yet

Changed 3 years ago by erikos

This is the nb view of C (red), B is in the activity, A is not in the activity yet

Changed 3 years ago by erikos

This is the nb view of B, everyone is in the activity A and C are drawn around the activity, the owner here A is always drawn in the middle and does not change position when in a shared activity

comment:8 Changed 3 years ago by erikos

  • Action Needed changed from review to test in build

sugar-0.92.2.9.gb092121-1.fc14.olpc.noarch.rpm, build 871

comment:9 Changed 3 years ago by erikos

  • Keywords tested added

Works for me, tested in 871 (keeping in mind that #10674 is not fixed yet).

The following test cases works fine:

  • A shares: the activity is added to the nb view of A but not next to the buddy of A who is centered in the middle (by design), the activity is added to the nb view of B with A clustered around
  • B joins: on the nb view of A buddy B is clustered around the activity, on the nb view of B buddy A is clustered around the activity
  • B leaves: on the nb view of A and B is repositioned
  • A leaves: activity is removed from the nb view of A, activity is removed from the nb view of B and A is repositioned

  • A shares: the activity is added to the nb view of A but not next to the buddy of A who is centered in the middle (by design), the activity is added to the nb view of B with A clustered around
  • A quits activity: the activity is removed from the nb view of A and B, on the nb view of B buddy A is repositioned

Due to #10674 the following does not work:

  • A shares
  • B joins
  • A leaves
  • B leaves

comment:10 Changed 3 years ago by dsd

Your test cases seem fine, great work :)

However if I modify the test case slightly to include invitations, things go wrong. Let me know if you would prefer this in a new ticket.

  • A opens chat, changes activity title
  • A goes to network view, invites B
  • B, on network view, sees the new shared activity
  • B accepts invitation by clicking on the invitation icon in the frame
  • A and B chat about the English summer weather for a while, everything seems fine (except the weather)
  • on B's network view, A and the shared chat icon have disappeared

Reproduced 2 out of 2 times, 11.2.0 candidate 871. A = XO-1. B = XO-1.5. communicating over ad-hoc.

comment:11 Changed 3 years ago by erikos

Thanks Daniel, good catch. I could reproduce it. At least on 0.84 the situation is only slightly better: on B's network only A disappears and the shared chat icon keeps being visible.

I would say, let's open a new ticket for that.

comment:12 Changed 3 years ago by erikos

Daniel, made the issue you describe #11048.

comment:13 Changed 3 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, I'm happy that the original test cases in this ticket are indeed working.

Note: See TracTickets for help on using tickets.