Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#10741 closed defect (fixed)

renaming a photo in Record corrupts it

Reported by: dsd Owned by: erikos
Priority: normal Milestone: 11.2.0-M4
Component: sugar-datastore Version: not specified
Keywords: Cc: greenfeld
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

See the sugar-devel mail "Bug or feature? metadata update truncates datastore entry"

If you take a photo in record, close the activity, resume the activity, then give the photo a new name, the photo will be lost due to a datastore bug.

Sascha Silbe worked on this bug a bit but its not clear if he finished.

[PATCH sugar-datastore 1/3] Add regression test for SL#2668
[PATCH sugar-datastore 2/3] Make sure data store checkouts are read-only
[PATCH sugar-datastore 3/3] don't destroy unchanged data store entries (SL#2668)
[PATCH sugar-toolkit] sugar.datastore.datastore: Avoid data update if the file hasn't been changed
[PATCH sugar-datastore] Avoid recalculating checksum on metadata-only update

Change History (8)

comment:1 Changed 4 years ago by dsd

  • Action Needed changed from review to package

probably fixed in sugar-0.90.1

comment:2 Changed 4 years ago by erikos

  • Action Needed changed from package to add to build
  • Cc greenfeld added

actually: sugar-datastore-0.92.1, is packaged for F14 and should be pulled in automatically if it gains enough karma points http://koji.fedoraproject.org/koji/buildinfo?buildID=239065, Sam maybe you can have a look and update the Karma points in bodhi.

https://admin.fedoraproject.org/updates/sugar-0.92.1-1.fc14,sugar-toolkit-0.92.1-1.fc14,sugar-datastore-0.92.1-1.fc14?_csrf_token=415c04e3f65583870926694b0d1da8623cefb94a

News

  • Release 0.92.1 (Simon Schampijer)
  • Make sure data store checkouts are read-only (Sascha Silbe)
  • don't destroy unchanged data store entries (SL#2668) (Sascha Silbe)

comment:3 follow-up: Changed 4 years ago by dsd

no karma points are needed for build inclusion, but it wont get included while your sugar-datastore public_rpms are blocking it

comment:4 Changed 4 years ago by greenfeld

I spent this weekend looking at Sugar in Fedora updates-testing, but had some issues getting the Network View (not relevant to this bug) to show shared activities. This may or may not be due to Fedora trailing the most recent fixes though.

I did notice some sugar-0.90 packages were left, so pbrobinson packaged Sugar-base and -artwork this morning to complete the 0.92 move on F14.

comment:5 in reply to: ↑ 3 Changed 4 years ago by erikos

Replying to dsd:

no karma points are needed for build inclusion, but it wont get included while your sugar-datastore public_rpms are blocking it

Oups, removed the custom packages - awaiting the F14 ones to be pulled in.

comment:6 Changed 3 years ago by dsd

  • Action Needed changed from add to build to test in build

test in 11.2.0-17

comment:7 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Renaming a photo within a resumed Record activity session does not delete its contents in 11.2.0-18.

comment:8 Changed 3 years ago by godiard

sugar-devel mail "Bug or feature? metadata update truncates datastore entry"

http://lists.sugarlabs.org/archive/sugar-devel/2011-March/030264.html

Tested the python code example test case and renaming files from Record in 872.

All ok.

Note: See TracTickets for help on using tickets.