Ticket #10751 (closed defect: fixed)

Opened 4 years ago

Last modified 20 months ago

Browse does not reliabily show title information

Reported by: greenfeld Owned by: humitos
Priority: normal Milestone: 11.3.0
Component: browse-activity Version: Development build as of this date
Keywords: Cc: manuq
Action Needed: diagnose Verified: no
Deployments affected: Blocked By:
Blocking:

Description

  1. Start a new clean instance of browse (i.e. not from a journal entry). Note that the OLPC homepage will not show a title
  2. Enter a website to go do in the titlebar such as www.google.com. The website's title will not appear for the site when loaded, and the busy cursor will not appear while loading the website.
  3. Continuing to browse around websites may eventually cause the manual website entry in the titlebar to disappear; but then it might not.

Seen in 11.2.0 os13 with Browse-120. This also occasionally seems to affect the Wikipedia-25 activities.

Change History

Changed 4 years ago by greenfeld

  • summary changed from Browse needs to show to Browse does not reliabily show title information

Changed 3 years ago by erikos

  • cc manuq added

Manuel, maybe you can diagnose the issue and see if/how we can fix it.

Changed 3 years ago by manuq

In 11.2.0 build os874, Browser 122:

  1. I start Browse as new activity, and see "OLPC Library" in the title.
  1. I enter www.google.com in the title bar, then hit enter. The reload tool button changes to stop, after a fraction of second the cursor changes to busy, the title changes to "Google", and the progress bar is shown in the text input.

greefeld, are you refering to the fraction of second it takes to show the busy cursor and the new title? Or maybe this is something fixed in current Browser?

Changed 3 years ago by erikos

Doing a quick test, I found the following smaller glitches:

- if the cursor is over the toolbar while loading it does not change to being a busy cursor

- if the cursor is over the entry field while loading it 'disappears'

- the title/address is not at the beginning after loading (e.g. of the title 'Get new ebooks from our store for free' 'ebooks from our store f' will be visible)

- some pages do not have a title ('mutter.de')

Ido agree with Manuel though, that I do not see the original reported issue.

Changed 2 years ago by humitos

  • owner changed from godiard to humitos
  • status changed from new to assigned

Changed 20 months ago by humitos

  • status changed from assigned to closed
  • resolution set to fixed

I was not able to reproduce this issue in Xo-4 13.1.0 os25.

Something related with this ticket was fixed some time ago: https://bugs.sugarlabs.org/ticket/851

Note: See TracTickets for help on using tickets.