Opened 4 years ago

Closed 3 years ago

#10778 closed enhancement (fixed)

OFW XO-1: 'menu' not implemented

Reported by: sridhar Owned by: Quozl
Priority: normal Milestone: Opportunity
Component: ofw - open firmware Version: not specified
Keywords: Cc: sridhar
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

If you type 'menu' at the ok prompt in openfirmware, you just get an array of empty boxes with no functionality.

See: http://lists.laptop.org/pipermail/devel/2011-March/031470.html

Attachments (1)

0001-disable-menu-10778.patch (777 bytes) - added by Quozl 4 years ago.
Indeed, yes, it's risky to actually remove it, and now the words in the same file are in active use by XO-1.5 dual-boot too. So here's what I intend: hide the word. Also my fix to allow use of screen(1) and Terminal as serial adapter hosts which I had already slipped into XO-1.5 and XO-1.75. Please review, Mitch.

Download all attachments as: .zip

Change History (18)

comment:2 Changed 4 years ago by erikos

  • Milestone changed from Not Triaged to 11.2.0-M4

Seen this as well in the 11.2.0 builds.

comment:3 Changed 4 years ago by erikos

  • Action Needed changed from never set to code
  • Version changed from not specified to Development build as of this date

comment:4 Changed 4 years ago by Quozl

  • Type changed from defect to enhancement
  • Version changed from Development build as of this date to not specified

Changed ticket type to enhancement, and cleared affected version field, since this was never implemented on XO-1.

menu on XO-1.5 exists primarily for factory use. Since XO-1 is no longer being manufactured, there's no need for menu at the factory. I think it is best that it be disabled in any future XO-1 firmware release, and so I'll take that on unless Mitch has other ideas.

comment:5 Changed 4 years ago by wmb@…

Please do take it on.

Be warned - removing the word "menu" risks either:

a) Removing other words defined in the same file that might in fact be used by the graphics infrastructure for pretty boot, or

b) Requiring the use of olpc-model-specific ifdefs in common code, a practice that I usually avoid.

In my opinion, this is a "not worth the effort and risk" item. The workaround is simple - don't type "menu". I a system with as many commands as OFW, there are probably dozens of other things you could type that wouldn't quite do what you want across platforms, so why single out this one?

That said, if you want to undertake the "fix" and are willing to do the testing to ensure that it doesn't have unintended side effects, be my guest.

Changed 4 years ago by Quozl

Indeed, yes, it's risky to actually remove it, and now the words in the same file are in active use by XO-1.5 dual-boot too. So here's what I intend: hide the word. Also my fix to allow use of screen(1) and Terminal as serial adapter hosts which I had already slipped into XO-1.5 and XO-1.75. Please review, Mitch.

comment:6 Changed 4 years ago by Quozl

  • Action Needed changed from code to test in build
  • Owner changed from wmb@… to Quozl
  • Status changed from new to assigned

Fixed in -r2180 and q2e45r. Sridhar, please test http://dev.laptop.org/~quozl/q2e45r.rom on XO-1. Typing menu should result in ok.

q2e45r has already been tested here to boot to ok, boot to 10.1.3, and reflash. Testing of other changes to -r2180 will be done in conjunction with #9564.

comment:7 Changed 4 years ago by Quozl

In further testing, q2e45r has been found to trigger #10597 on 10.1.3 after resume from suspend, symptom cleared by reboot, symptom reproduces every resume, symptom reproduces on resume from echo mem > /sys/power/state.

comment:8 Changed 4 years ago by Quozl

q2e45r triggers #10597 independently of year set in RTC; tested 2010 and 2011.

comment:9 Changed 4 years ago by Quozl

The cause of the #10597 symptom was a regression to EC firmware version PQ2E34 from PQ2E35 which was shipped in Q2E45. Fixed in -r2181 and q2e45s. Sridhar, please test http://dev.laptop.org/~quozl/q2e45s.rom on XO-1. Typing menu should result in ok.

comment:10 Changed 4 years ago by sridhar

q2e45s.rom appears to do as advertised. I typed 'menu' and just got ok. Tested on XO with S/N SHC832038CC. Thanks Quozl.

comment:11 Changed 4 years ago by Quozl

  • Action Needed changed from test in build to package

Thanks Sridhar. It should be in the next release of XO-1 firmware.

comment:12 Changed 4 years ago by martin.langhoff

Looks like this can land!

comment:13 Changed 4 years ago by dsd

  • Keywords dsd-11.3.0? added
  • Milestone changed from 11.2.0-M4 to Future Release

Not ready in time for 11.2.0; very welcome in a future development window.

comment:14 Changed 3 years ago by Quozl

  • Action Needed changed from package to no action
  • Resolution set to fixed
  • Status changed from assigned to closed

Included in Q2E46.

comment:15 Changed 3 years ago by Quozl

  • Action Needed changed from no action to test in build
  • Keywords dsd-11.3.0? removed
  • Milestone changed from Future Release to Opportunity
  • Resolution fixed deleted
  • Status changed from closed to reopened

#11622 requested the diagnostics menu be implemented, and a test version is available in that ticket.

comment:16 Changed 3 years ago by Quozl

  • Action Needed changed from test in build to add to release

comment:17 Changed 3 years ago by Quozl

  • Action Needed changed from add to release to no action
  • Resolution set to fixed
  • Status changed from reopened to closed

Is in Q2F07.

Note: See TracTickets for help on using tickets.