Opened 3 years ago

Last modified 3 years ago

#10964 assigned defect

XO-1.75 A3 panel image persists after power down

Reported by: Quozl Owned by: wad
Priority: blocker Milestone: Future Release
Component: hardware Version: 1.75-A3
Keywords: XO-1.75 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: add to build
Verified: no

Description

The displayed image persists on the panel after power down, gradually fading over 5.2 seconds. Occurs both with power button and sudden removal of main battery. Occurs in OpenFirmware and in Linux. Cardboard tag says this is unit 4. Does not occur on XO-1.75 A2, XO-1.5, or XO-1.

Change History (2)

comment:1 Changed 3 years ago by wad

  • Action Needed changed from diagnose to add to build
  • Keywords XO-1.75 added
  • Milestone changed from Not Triaged to Future Release
  • Priority changed from normal to blocker
  • Status changed from new to assigned

This occurs on all A3 prototypes, and is due to improper power sequencing of the display.

It has happenened before (XO-1 B3 ?). This will be fixed in B-phase.

comment:2 Changed 3 years ago by wad

In order to induce a clean sweep, the power to the display driver ICs (LCD_+1.8V)
must persist until after the VCOM voltage decays. With A3, the +1.8V rail decays
very quickly, and pulls down LCD_+1.8V through the body diode of PQ22.

Richard was able to fix this in software by turning off the DCON (and hence
EN_LCD_PWR) 5 mS before turning off EN_MAIN_PWR.
It will be included in the next firmware release.

Note: See TracTickets for help on using tickets.