Opened 3 years ago

Closed 3 years ago

#11065 closed defect (fixed)

File transfer can not be removed when sender quits

Reported by: erikos Owned by: erikos
Priority: normal Milestone: 11.3.0
Component: sugar Version: Development build as of this date
Keywords: collaboration, no92regression Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: package
Verified: no

Description

  • A: send file to B
  • A: quits
  • B: try to accept file-transfer (activity-frame), click 'resume'

---> nothing happens and the item can not be removed from the Frame

Message in log is:

Traceback (most recent call last):
  File "/home/erikos/sugar-jhbuild/install/lib/python2.7/site-packages/jarabe/frame/activitiestray.py", line 660, in __resume_activate_cb
    self.file_transfer.resume()
AttributeError: 'IncomingFileTransfer' object has no attribute 'resume'

Change History (5)

comment:1 Changed 3 years ago by erikos

  • Keywords no92regression added

Tested in 10.1.3 and was present there as well.

comment:2 Changed 3 years ago by erikos

Another case that does not work is:

  • A: send file to B
  • A: cancel transfer
  • B: try to accept file-transfer (activity-frame) by clicking 'Accept'

---> the palette does show now 'Resume' and can not be removed anymore

  • if B clicks 'Decline' after A has canceled the file transfer item in the Frame will be removed.

comment:3 Changed 3 years ago by erikos

  • Action Needed changed from diagnose to review

comment:4 Changed 3 years ago by erikos

  • Action Needed changed from review to package

comment:5 Changed 3 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

Works for me in os7.

Note: See TracTickets for help on using tickets.