Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#11095 closed enhancement (fixed)

Lid switch OFW power off should be consistent across XO versions

Reported by: greenfeld Owned by: greenfeld
Priority: normal Milestone:
Component: ofw - open firmware Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Boot an unlocked XO and break into Open Firmware. Then close the XO fully without turning it off.

An XO-1.5 with Q3B14 will shut itself off after 8 seconds since it detects the lid switch is activated (unless you open it up in time, or enter "lid-off" to disable the feature). An XO-1 with Q2B45 does not turn off, and an XO-1.75 B1 with Q4B05 does not turn off.

If we are not concerned about stuck lid switches then perhaps we should be consistent about this across all product versions.

Change History (11)

comment:1 Changed 3 years ago by Quozl

The risks associated with stuck lid switches are entirely different across product versions, so consistency is not required.

comment:2 Changed 3 years ago by greenfeld

But we are consistent across platforms (except for the XO-1.75, which currently cannot suspend) in suspending the XO when it is closed in Linux, correct?

If so then perhaps we should make OFW consistent with powerd's default behavior.

comment:3 Changed 3 years ago by Quozl

I don't know about Linux, sorry. I've not checked for consistency there. We failed consistency in power management because there were differences or difficulties, but I don't recall the details. Feel free to test again and raise another ticket.

I don't think OpenFirmware needs to be consistent with powerd, since the OpenFirmware ok prompt is not expected to be used frequently by the end-user, and there is no need for it in the current thermal configuration. That's my opinion. Others welcome.

comment:4 Changed 3 years ago by wmb@…

  • Action Needed changed from never set to test in release

Fixed by svn 2573. The fix will appear in q4b11.

comment:5 Changed 3 years ago by wmb@…

  • Owner changed from wmb@… to greenfeld

comment:6 Changed 3 years ago by greenfeld

  • Action Needed changed from test in release to no action
  • Resolution set to fixed
  • Status changed from new to closed

We now detect the lid switch and power off an XO-1.75 in Q4B11.

comment:7 Changed 2 years ago by Quozl

  • Action Needed changed from no action to add to build
  • Milestone 1.75-firmware deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Lid switch OFW power off should be consistant across XO versions to Lid switch OFW power off should be consistent across XO versions
  • Version 1.75-B1 deleted

The lid switch power off has become useful, but recent work on XO-1 has made the lack of it irritating to me, so I've fixed it in svn 2991.

comment:8 Changed 2 years ago by Quozl

  • Action Needed changed from add to build to add to release

comment:9 Changed 2 years ago by Quozl

  • Action Needed changed from add to release to no action
  • Resolution set to fixed
  • Status changed from reopened to closed

Is in Q2F12.

comment:10 Changed 2 years ago by Quozl

Is in Q3C07, though no change to behaviour. Only a source code move with no functional effect.

comment:11 Changed 2 years ago by Quozl

This enhancement introduced an unexpected behaviour on XO-1, see #12077.

Note: See TracTickets for help on using tickets.