Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11131 closed defect (fixed)

XO-1.75 os36 cannot automount a USB HDD with NTFS

Reported by: Quozl Owned by: pbrobinson
Priority: normal Milestone: 1.75-software
Component: distro Version: Development build as of this date
Keywords: Cc: pbrobinson, tonyforster
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description (last modified by greenfeld)

This appears to be at least partially a packaging difference.

11.3.0 os3 contains:

  • ntfs-3g-2011.4.12-3.fc14.i686
  • ntfsprogs-2011.4.12-3.fc14.i686

XO-1.75 os41 contains:

  • no ntfs-3g package
  • ntfsprogs-2.0.0-15.fc14.armv5tel {Versioning scheme may have changed}

The preferred mechanism nowadays as far as I know is to access NTFS via ntfs-3g (FUSE-based), which supposedly has superior read/write support. It looks like ntfsprogs may have other potentially useful programs though.

Change History (11)

comment:1 Changed 3 years ago by Quozl

  • Blocked By 11113 added

Missing NTFS support is possibly caused by #11113.

comment:2 Changed 3 years ago by greenfeld

  • Cc pbrobinson added
  • Description modified (diff)

comment:3 Changed 3 years ago by Quozl

  • Action Needed changed from never set to add to build
  • Blocked By 11113 removed
  • Component changed from not assigned to distro
  • Owner set to pbrobinson

comment:4 Changed 3 years ago by pbrobinson

Correct, added temporarily until I get time to work out why its getting pulled in by something on x86 builds but not arm. Will be in OS5

comment:5 Changed 3 years ago by Quozl

  • Action Needed changed from add to build to test in build

Test in os5.

comment:6 follow-ups: Changed 3 years ago by martin.langhoff

Did we ever support NTFS disks? Maybe we should stay away from this can of worms...

comment:7 Changed 3 years ago by Quozl

Martin, as this was a Quanta test plan fail from 2011-08-10 (issue 22), perhaps you could direct them not to test NTFS for C1?

comment:8 in reply to: ↑ 6 Changed 3 years ago by pbrobinson

Replying to martin.langhoff:

Did we ever support NTFS disks? Maybe we should stay away from this can of worms...

most 500+gb external hdds and all 2+tb or 4kb sector disks come formated with ntfs due to vfat limitations so do we want to open the associated support can of worms if we don't?

comment:9 in reply to: ↑ 6 Changed 3 years ago by tonyforster

  • Cc tonyforster added

Replying to martin.langhoff:

Did we ever support NTFS disks? Maybe we should stay away from this can of worms...

os373pyg Sugar 0.88 supports NTFS. I have a HP Simplesave HDD which works well on Sugar and Gnome

comment:10 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Mounted a 1 TB USB NTFS hard drive on an XO-1.75 in 11.3.0 os883.

comment:11 Changed 3 years ago by tonyforster

HP Simplesave half terrabyte drive mounts OK in OS883

Note: See TracTickets for help on using tickets.