Opened 3 years ago

Closed 3 years ago

#11175 closed defect (fixed)

some keyboard keys repeat when they should not

Reported by: tonyforster Owned by: erikos
Priority: normal Milestone: 11.3.0
Component: sugar Version: Development build as of this date
Keywords: blocker? Cc: dsd
Blocked By: Blocking: #11264
Deployments affected: Action Needed: test in build
Verified: no

Description

XO-1.75 OS40 clicky HS keyboard
no autorepeat

Change History (17)

comment:1 Changed 3 years ago by Quozl

  • Action Needed changed from never set to reproduce
  • Version changed from not specified to Development build as of this date

Doesn't reproduce here on XO-1.75 with mechanical keyboard, but I'm using Q4B08. Tried in virtual console and terminal, using the g key. Both worked fine.

comment:2 Changed 3 years ago by tonyforster

Mine is q4b07

Easily reproduced here, rebooted twice and still there

test case: journal search or rename journal entry or Terminal

comment:3 Changed 3 years ago by greenfeld

Upgrading to Q4B08 might help os40 determine how your 1.75 is equipped a bit better.

Keyboard repeats work for me in os40/Q4B08 for XO-1.75 on the Linux text console and at the Open Firmware prompt. X Windows/Sugar does not show repeat working for most alphanumeric keys, but it does work for keys like the backspace key. Tested with both mechanical and membrane keyboards.

Paul Fox notes this may be intentional; /usr/bin/sugar-session has an xset -r line which disables autorepeat for "several keys" and then goes on to name a few dozen. But os2/11.3.0 on XO-1/XO-1.5 does not disable autorepeat in Sugar, or something is re-enabling it.

comment:4 Changed 3 years ago by tonyforster

upgraded to q4b08, repeat does not function in sugar or gnome

tried firmware prompt , repeat works there

comment:5 Changed 3 years ago by pgf

i believe this is working as intended. disable the "xset -r ...." command in /usr/bin/olpc-session, and repeat will function fully. i believe disabling repeat was done for the sake of the children, but i can't say for sure -- the behavior pre-dates my time at OLPC. (ah -- see #1201)

i just checked an XO-1 running 10.1.3 (build 360), and another running something much older, and both have repeating arrows and backspaces, but not printing characters. (i'm referring to X behavior -- repeating works fully in a VT console.)

however, i do see that 11.3.0 builds, both os1 and os2, have full repeating -- which implies a bug, since i think olpc-session there should be the same.

comment:6 Changed 3 years ago by Quozl

  • Summary changed from Keyboard doesnt repeat to some keyboard keys repeat when they should not

agreed, we should fix 11.3.0 to turn off autorepeat, rather than introduce autorepeat on populations that have never had it before.

comment:7 Changed 3 years ago by dsd

  • Action Needed changed from reproduce to diagnose
  • Cc dsd added
  • Keywords blocker? added
  • Milestone changed from 1.75-software to 11.3.0

Seems like we have a regression in 11.3.0 indeed, and an important one IMO. Will look into this.

comment:8 Changed 3 years ago by dsd

  • Component changed from not assigned to sugar
  • Owner set to erikos

Initial diagnosis: setup_keyboard_cb in /usr/bin/sugar-session is applying keyboard settings, which override the autorepeat disable settings that were programmed previously by olpc-session.

comment:9 Changed 3 years ago by dsd

This bug is also in 11.2.0 so actually it is a regression over 10.1.x. The keyboard dialog support code is applying keyboard settings even if the user didn't choose any, overriding whatever the system might have set.

Fixed with:

comment:10 Changed 3 years ago by martin.langhoff

  • Blocking 11264 added

(In #11264) In fact, disabling setup_keyboard_cb in sugar-session fixes the issue.

comment:11 Changed 3 years ago by dsd

  • Action Needed changed from diagnose to add to build

committed upstream and included in sugar-0.94.0.7.gf01a6c3-1.fc14.olpc

comment:12 Changed 3 years ago by dsd

  • Action Needed changed from add to build to test in build

test in 11.3.0 candidate build 881

comment:13 Changed 3 years ago by tonyforster

OS881, alphanumeric keys do not repeat, del, backspace and cursor keys do repeat

comment:14 Changed 3 years ago by godiard

Tested with mechanichal and membrane keyboard in os881, alphanumeric keys do not repeat, del, backspace and cursor keys do repeat

comment:15 Changed 3 years ago by tonyforster

Tested OK in OS882

comment:16 Changed 3 years ago by erikos

Tested as working fine in upcoming 883.

comment:17 Changed 3 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

Two persons tested positively, closing.

Note: See TracTickets for help on using tickets.