Ticket #11196 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

some 1.75 touchpads "wander" in ebook mode

Reported by: pgf Owned by: wad
Priority: high Milestone: 1.75-hardware
Component: hardware Version: not specified
Keywords: 11.3.0 Cc: tonyforster, carrott
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description (last modified by Quozl) (diff)

on three or four mechanical keyboard 1.75 models i've tried: the cursor begins to "wander" on its own as soon as its put into ebook configuration. this can be observed both in OFW with "test /mouse" or under X. the kernel identifies these touchpads as "ImExPS/2 Generic Explorer Mouse" -- they may be AVC touchpads, since our kernels don't include the Sentelic driver that would be specific to the AVC touchpads.

i've found one AVC laptop in the cambridge office, and it too exhibits the ebook wandering behavior, though it feels like it's to a lesser extent than on the 1.75 models.

the two membrane keyboard 1.75 models i've tried do _not_ exhibit this behavior. those laptops both have Synaptics touchpads.

Change History

Changed 3 years ago by Quozl

  • description modified (diff)

seen here on a unit with mechanical keyboard and touchscreen, the unit also reproduced #11171.

another unit that reproduced #11171 did not reproduce #11196, and it has no touchscreen.

does your unit have a touchscreen?

Changed 3 years ago by pgf

i've seen it on units both with and without touchscreen.

i built a kernel that included the Sentelic driver, and the touchpads in the mech. keyboard units is identified as a sentelic.

Changed 3 years ago by tonyforster

  • cc tonyforster added

Changed 3 years ago by Quozl

  • cc carrott added
  • description modified (diff)

Per comment in #11171, a touchpad wanders also if fitted into an XO-1.5 C2.

Changed 3 years ago by carrott

Our jumpy and wandering touchpad is a Sentelic, or at least has their logo on it. See http://dev.laptop.org/attachment/ticket/11171/XO-1.75-sentelic-jumpy.jpg (sorry for the blurry, I shouldn't have used the phonecam!)

Changed 3 years ago by pgf

warning: olpc-kbdshim-20, which will likely appear in os6, will mask this symptom.

to test, either:

# strace -p $(pidof olpc-kbdshim-udev)

and watch for continuous activity unrelated to user input, or probably easier:

# stop olpc-kbdshim-udev

which will shut down kbdshim and let the suppressed events through.

Changed 3 years ago by tonyforster

OS6, kbdshim might be reducing the wandering but it is not stopping it. Seems to wander most in the first few seconds in ebook mode then only small cursor movements thereafter. With kbdshim stopped the larger cursor movements seem to continue.

Changed 3 years ago by pgf

turns out os6 still has olpc-kbdshim-19, so no change was to be expected.

Changed 3 years ago by greenfeld

  • keywords 11.3.0 added
  • next_action changed from never set to add to build

Changed 3 years ago by greenfeld

  • next_action changed from add to build to test in build

olpc-kbdshim-20 is in os7

Changed 3 years ago by tonyforster

OS7, its looking like its fixed here

Changed 3 years ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

Verified a touchpad wondered in eBook mode on a 1.75 HS using OFW's "test /mouse"

Booted into 11.3.0 os3 and verified that all touchpad input was suppressed and ignored while the XO was in ebook mode, yet worked after exiting ebook mode.

An external USB keyboard & mouse still worked regardless of if we were in ebook mode or not.

Changed 3 years ago by pgf

  • status changed from closed to reopened
  • resolution deleted

this is the wrong outcome for this bug. or, rather, it might be the right outcome, but it's for the wrong reasons.

the goal is not to mask the wandering behavior. the goal is to build laptops whose touchpads don't wander in ebook mode. the kdbdshim change is really more of a "suppress errant button presses while in ebook mode" thing, not a "correct for bad hardware" thing.

Changed 3 years ago by greenfeld

For the record this is still an issue with C1 units, but only to the extent I see the issue with our B1 units with AVC touchpads.

To reproduce, either stop olpc-kbdshim-udev as above (since it masks the symptom), or run "test /mouse" in OFW, and immediately put the XO into ebook mode. Rubbing your fingers against the back of the XO (in ebook mode) or moving the XO across your leg should show cursor movement, although I could not recreate any significant wild jumps all over the place.

Changed 2 years ago by martin.langhoff

  • status changed from reopened to closed
  • resolution set to fixed

A temporary fix has been implemented in olpc-kbdshim, and can be seen in OS26. olpc-kbdshim ignores touchpad input while in ebook mode.

A better solution is tracked at #11607.

Changed 2 years ago by martin.langhoff

Note:

We tried to suppress TP input while in ebook mode by tweaking the TP configuration on AVC touchpads. This can be seen in AVC touchpads with "3F" and "4F" configurations; which succeeded in suppressing input while in ebook mode, but had poor results in other use cases (#11581).

Part of the fix for #11581 is to undo that change.

One of the implications is that testing under OFW is not effective.

Note: See TracTickets for help on using tickets.