Ticket #11304 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

11.3.0 build 8 is not dimming, powering off the screen backlight on XO-1

Reported by: garycmartin Owned by:
Priority: normal Milestone: 11.3.0
Component: olpc-utils Version: Development build as of this date
Keywords: Cc:
Action Needed: test in build Verified: no
Deployments affected: Blocked By:
Blocking:

Description

11.3.0 build 8 (or 7) is not dimming, or powering off the screen backlight on an XO-1 during idling. The screen backlight is on all the time vs. the XO1.75 behaviour that dims after a few moments of being left alone and then soon powers off the backlight.

Attachments

powerd_xo-1.trace (96.9 kB) - added by garycmartin 3 years ago.
Log from XO-1
powerd-xo_1-75.trace (18.6 kB) - added by garycmartin 3 years ago.
Log taken from xo-1.75 at the same time (waited for its backlight to power off to take the logs)

Change History

  Changed 3 years ago by garycmartin

  • version changed from not specified to Development build as of this date

Re-testing in 11.3.0 build os882, the XO-1 is still not powering off or dimming the screen backlight when idle - this is a regression from previous olpc official releases (11.2.0).

  Changed 3 years ago by Quozl

  • next_action changed from never set to diagnose
  • milestone changed from Not Triaged to 11.3.0

follow-up: ↓ 4   Changed 3 years ago by pgf

if someone could attach a powerd.trace file, obtained after "powerd-config =trace-debug", it would be helpful. do some keyboard activity just after enabling trace-debug, then don't touch the laptop again for at least 5 minutes. then save a copy of the log.

Changed 3 years ago by garycmartin

Log from XO-1

Changed 3 years ago by garycmartin

Log taken from xo-1.75 at the same time (waited for its backlight to power off to take the logs)

in reply to: ↑ 3   Changed 3 years ago by garycmartin

Replying to pgf:

if someone could attach a powerd.trace file, obtained after "powerd-config =trace-debug", it would be helpful. do some keyboard activity just after enabling trace-debug, then don't touch the laptop again for at least 5 minutes. then save a copy of the log.

Logs attached, I did an XO-1.75 and XO-1 at the same time for comparison and waited for the 1.75 to power off its back light (takes a little longer than 5min).

  Changed 3 years ago by dsd

  Changed 3 years ago by pgf

i'm confused by this. historically XO-1 has had hooks in the X server which made DPMS work correctly. but we disabled it in any case, so that powerd had full control of blanking.

i agree that martin's patch seems to be introducing the disable of DPMS, but powerd should be doing the right thing in any case. (and the log that gary attached looks like it's working correctly.)

  Changed 3 years ago by dsd

  • owner pgf deleted
  • next_action changed from diagnose to code
  • component changed from power manager (powerd) to olpc-utils

DPMS on XO-1 has been enabled in recent releases (10.x/11.x at least). I agree that giving powerd control of this is a nicer solution, but it's not working for whatever reason.

As time is too short to diagnose the powerd issue, we're going to re-enable XO-1 DPMS for 11.3.0 so that we don't ship a release which leaves the screen on. This is not perfect but matches the behaviour of 11.2.0. We can then diagnose the powerd issue for future releases.

  Changed 3 years ago by dsd

  • next_action changed from code to add to build

XO-1 DPMS re-enabled in olpc-utils-1.3.7

#11364 filed for the powerd fix.

  Changed 3 years ago by pgf

the behavior, and the supplied logfile, are consistent with power management being disabled from the control panel (i.e., /etc/powerd/flags/inhibit-suspend is present). i understand that this is the default behavior, since power management is disabled on XO-1 releases. but i thought it had been the default for some time, so i don't understand the "regression" aspect of this bug.

  Changed 3 years ago by dsd

  • next_action changed from add to build to test in build

test in 11.3.0 candidate build 883

  Changed 3 years ago by dsd

test case: boot XO-1, leave on for 30 minutes without using it, check screen blanks after a while

  Changed 3 years ago by godiard

  • status changed from new to closed
  • resolution set to fixed

working on os883

Note: See TracTickets for help on using tickets.