Opened 3 years ago

Closed 3 years ago

#11321 closed defect (fixed)

Write freezes laptop on scrolling

Reported by: tonyforster Owned by: jnettlet
Priority: high Milestone: 1.75-software
Component: x window system Version: Development build as of this date
Keywords: Cc: greenfeld
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Getting a total laptop freeze when initiating a scroll in Write by using the cursor key to go below the bottom of the screen

OS880 XO-1.75 (Write77)

Checked scrolling in Pippy and Log and they are OK

Attachments (1)

Xorg.0.log (72.4 KB) - added by greenfeld 3 years ago.
Xorg log from an X crash in 11.3.1 os25 due to scrolling in the Write activity

Download all attachments as: .zip

Change History (22)

comment:1 Changed 3 years ago by dsd

  • Component changed from write-activity (abiword) to x window system
  • Owner changed from uwog to jnettlet

Nice find - reproduced. I suspect a video driver issue.

Test case: open write, hold down the enter key for about 30 seconds so that you are creating a mass of new lines and extending the document canvas more and more. Soon the whole system will hang.

comment:2 Changed 3 years ago by tonyforster

present in os883

comment:3 Changed 3 years ago by Quozl

Also reproduces on 11.3.1 os10, the system hangs, but not for long, X restarts.

comment:4 Changed 3 years ago by Quozl

  • Priority changed from normal to high
  • Version changed from not specified to Development build as of this date

Also reproduces on 11.3.1 os14, the display hangs, but serial port remains usable.

Also reproduces on kernel dfde663.

comment:5 Changed 3 years ago by Quozl

Also reproduces on 11.3.1 os14 with kernel 63ab5b1 and xorg-x11-drv-dove-0.1.0-8.olpc

comment:6 Changed 3 years ago by Quozl

  • Action Needed changed from never set to test in build

A fix is available, says Jon. os24 plus additional packages, being tested.

comment:7 follow-up: Changed 3 years ago by erikos

Me bad :/ I managed to get the machine to freeze when scrolling in Write in os25.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 3 years ago by tonyforster

Replying to erikos:

Me bad :/ I managed to get the machine to freeze when scrolling in Write in os25.

but it is different,before it was 100% faulty, now i cant fault it

comment:9 in reply to: ↑ 8 ; follow-up: Changed 3 years ago by erikos

Replying to tonyforster:

Replying to erikos:

Me bad :/ I managed to get the machine to freeze when scrolling in Write in os25.

but it is different,before it was 100% faulty, now i cant fault it

I have not seen the behavior before, so I can not compare. If it is better now, great. Though I managed to freeze the machine while scrolling continiously a long text.

comment:10 in reply to: ↑ 9 Changed 3 years ago by godiard

Replying to erikos:

Replying to tonyforster:

Replying to erikos:

Me bad :/ I managed to get the machine to freeze when scrolling in Write in os25.

but it is different,before it was 100% faulty, now i cant fault it

I have not seen the behavior before, so I can not compare. If it is better now, great. Though I managed to freeze the machine while scrolling continiously a long text.

Before, the first scroll frozen the machine.

comment:11 Changed 3 years ago by martin.langhoff

So now is less likely to hit? Simon, what are your steps to repro?

comment:12 Changed 3 years ago by martin.langhoff

Also, please test related bug #11399 -- likely a duplicate, but the repro steps are different...

comment:13 Changed 3 years ago by erikos

In my testing I did copy text into the sheet, again and again until I had a large document and then did continiously scroll (finger pressend on arrow keys) until the system hung. I tried to reproduce now another time with the same procedure but couldn't. Tried as well like said in #11399, but still no hang.

comment:14 Changed 3 years ago by martin.langhoff

  • Cc greenfeld added

Hmmm, we need a second opinion here. Sam -- think you can try to force this one to happen?

comment:15 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

This appears to be fixed in 11.3.1 os25; but that is not surprising in that one of the planned changes to the graphics driver was to fix Write so it could handle multipage documents better.

comment:16 Changed 3 years ago by greenfeld

  • Action Needed changed from no action to diagnose
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening since we do potentially crash in 11.3.1 os25. It just may take a lot of scrolling up and down to do so.

Once a user scrolls off the end of the screen of a document using the arrow keys, there are kernel messages like these for every line shifted on/off screen due to scrolling:

[ 2563.776426] [GC_gcmkONERROR  ] gckKERNEL_Dispatch(773): status=-3
[ 2563.808668] gckOS_MapUserMemory: address is 3d2678, cannot satisfy alignment request! 

Changed 3 years ago by greenfeld

Xorg log from an X crash in 11.3.1 os25 due to scrolling in the Write activity

comment:17 Changed 3 years ago by Quozl

  • Action Needed changed from diagnose to test in build

Please test again in os26, as factory says this is fixed.

comment:18 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to diagnose

Reproduced just now in os26. Stack trace (if you get one in Xorg.0.log before X dies) is identical to that attached to the ticket from os25.

To easily reproduce, randomly create a few pages of 0-3 characters of gibberish per line, quit Write to save the document, restart Write with said document, and hold down the down arrow key.

comment:19 Changed 3 years ago by jnettlet

Can you please test this rpm and see if it fixes this problem. http://dev.laptop.org/~jnettlet/f14/xorg-x11-drv-dove-0.3.4-4.olpc.armv5tel.rpm

comment:20 Changed 3 years ago by martin.langhoff

  • Action Needed changed from diagnose to test in build

In OS28, please test.

comment:21 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from reopened to closed

Seems to be fixed in 11.3.1 os28.

Note: See TracTickets for help on using tickets.