Opened 3 years ago

Closed 3 years ago

#11335 closed defect (fixed)

Specialized Sugar keys on XO-1 Keyboard not working after battery pull

Reported by: greenfeld Owned by: wmb@…
Priority: normal Milestone: 11.3.0
Component: ofw - open firmware Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

  1. Take an XO-1 running Q2E46 firmware, disconnect it from external power.
  2. Remove the battery from the XO-1, then re-insert it.
  3. Boot the XO-1 and press ESC one to break into OFW at the startup sound.
  4. Run "test /keyboard". The following keys will not register:
  • Language switcher (or ">/<" or "%/X" depending on the model)
  • Frame key
  • Search (magnifying glass) key
  • "fn" key
  • The key with two rectangles on it next the frame key (not sure what it does)
  • The Grab key next to the "fn" key

All other keys (F1-F12 equivalents & alphanumeric) along with the gamepad for seem to be fine.

Bug easily reproduced on CSN7480410B, SHC93004B6F, & SHC9300208D.

More diagnosis is needed, as I just verified with one of these XO-1's that the special keys used by Sugar work in 11.3.0 os880. On the *10B machine the problem was not seen until I upgraded from Q2E45 to Q2E46, although I would need to downgrade to see if that potentiality is a false clue.

Change History (5)

comment:1 Changed 3 years ago by greenfeld

All three XO-1s were using EnE/Synaptics keyboards.

comment:2 Changed 3 years ago by greenfeld

  • Component changed from embedded controller to ofw - open firmware
  • Owner changed from rsmith to wmb@…

Further testing suggests this is indeed a regression in Q2E46 from Q2E45. Both have the same EC firmware (PQ2E35), so perhaps this is an open firmware issue?

When the keys do not work in OFW's keyboard test, they also do not work in Linux/Sugar as well. Booting into OFW is not a prerequisite for the specialized keys not working.

Further reboots & power cycles without removing the battery may or may not have all the keyboard keys working after the issue is spotted. Removing external power & pulling the battery causes the issue to occur again.

comment:3 Changed 3 years ago by wmb@…

Fixed by svn 2604.

comment:4 Changed 3 years ago by Quozl

  • Action Needed changed from diagnose to test in build

Test in q2e48.

comment:5 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Issue fixed in Q2E48.

Note: See TracTickets for help on using tickets.