Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11336 closed defect (fixed)

Q2E46 does not automatically pick up new firmware builds.

Reported by: greenfeld Owned by: wmb@…
Priority: high Milestone: 11.3.0
Component: ofw - open firmware Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

  1. Install 11.3.0 os881 (which has bootfw-q2e47-1.unsigned.i386) on an XO-1 which has Q2E46 installed.
  2. Attach the XO to external power and boot it.
  3. The XO will not attempt to upgrade to Q2E47 automatically.
  4. Flash Q2E45 manually onto the XO. With external power attached it will automatically install Q2E47.

Change History (9)

comment:1 Changed 3 years ago by wmb@…

is the machine secure or not

comment:2 Changed 3 years ago by greenfeld

The machine is not secured.

Running in simulated secure & verbose mode we are told "int:\boot\bootfw.zip - current FW is up to date"

Running in insecure but verbose mode I see no such message.

comment:3 Changed 3 years ago by wmb@…

  • Action Needed changed from diagnose to add to build

Fixed by svn 2603.

For systems with Q2E46, the auto-reflash can be made to work by typing this:

ok patch get-encoded-string decode-string ofw-model$
ok boot

The problem also exists in Q2E47, but will be fixed in the next build that picks up svn 2603.

comment:4 Changed 3 years ago by Quozl

  • Action Needed changed from add to build to test in build

Test in q2e48.

comment:5 Changed 3 years ago by dsd

Tested by creating a "fake" q2e50, signing it, putting it on local NAND. Then I booted Q2E45, Q2E46, Q2E47 and Q2E48 without power attached. Q2E46 and Q2E47 didn't try to upgrade (before complaining about power), but Q2E45 and Q2E48 attempted to upgrade.

Seems to be fixed in Q2E48 - thanks.

comment:6 Changed 3 years ago by Quozl

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Thanks.

comment:7 Changed 3 years ago by dsd

also confirmed that the following firmware releases do not have this issue: Q3B13, Q3B19, Q3B20, Q4B12

comment:8 Changed 3 years ago by dsd

Recovery procedure for XO-1 users running Q2E46 and Q2E47:

  1. Download http://dev.laptop.org/pub/firmware/q2e48/q2e48.rom to a USB disk
  2. If the laptop is secured, obtain a developer key (see http://wiki.laptop.org/go/Activation_and_developer_keys) and put it on the USB disk too.
  3. Connect the affected XO to AC mains power and ensure that a good battery is inserted
  4. Boot to the "ok" firmware prompt (see http://wiki.laptop.org/go/Ok)
  5. at the ok prompt, type: flash u:\q2e48.rom
  6. The laptop will install the new firmware and automatically reboot. You are now running the latest firmware and upgrades to newer firmware releases will happen automatically as before.

comment:9 Changed 3 years ago by greenfeld

Why force the XO to be unlocked?

If we are confident Q2E48 looks good, we should have it independently signed and put the signed version online for use, like we have for previous preferred firmware versions.

Note: See TracTickets for help on using tickets.