Ticket #11358 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

New XO-1.5 firmware Q3B22

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 11.3.0
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

This fixes:

  • ok prompt issue
  • Possible partial fix for EC charging issues (hoping for Richard's clarification on this change)

Change History

Changed 2 years ago by dsd

Paul says that the remaining delta between 2.2.8(Q3B19) and 2.2.10(Q3B22) includes just one functional change: we suppress the algorithm that tries to determine whether we're being powered by an adapter or a solar panel when external power is first plugged in. this algorithm was causing crashes when you plugged an adapter into a laptop with a very low battery.

Changed 2 years ago by dsd

  • next_action changed from add to build to test in build

test in 11.3.0 candidate build 883

Changed 2 years ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

Tested Q3B22 firmware in 11.3.0 os883 (including trying to reproduce the reboot when charging a critically low XO) and it seems to be working properly.

Note: See TracTickets for help on using tickets.