Ticket #11378 (closed defect: worksforme)

Opened 3 years ago

Last modified 19 months ago

Browse RuntimeError: maximum recursion depth exceeded

Reported by: tonyforster Owned by: erikos
Priority: normal Milestone: 1.75-software
Component: browse-activity Version: not specified
Keywords: Cc:
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I have had this on the XO-1.75 a few times OS883 (and maybe earlier) No website in particular, maybe related to the bad alloc bug

Error in sys.excepthook: Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/sugar/logger.py", line 72, in _except_hook

from IPython.ultraTB import AutoFormattedTB

RuntimeError: maximum recursion depth exceeded

Original exception was: RuntimeError: maximum recursion depth exceeded Error in sys.excepthook: Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/sugar/logger.py", line 72, in _except_hook

from IPython.ultraTB import AutoFormattedTB

RuntimeError: maximum recursion depth exceeded

Original exception was: RuntimeError: maximum recursion depth exceeded ** (sugar-activity:22965): DEBUG: Got client ID "106cfa44184915099f132029925962541600000009210012" ** (sugar-activity:22965): DEBUG: Setting initial properties ** (sugar-activity:22965): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle ** (sugar-activity:22965): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself ** (sugar-activity:22965): DEBUG: Received SaveComplete message in state save-yourself-done /home/olpc/Activities/Browse.activity/webtoolbar.py:74: GtkWarning: IAgtk_entry_set_text: assertion `text != NULL' failed

self.props.text = text

Change History

Changed 19 months ago by humitos

  • status changed from new to closed
  • resolution set to worksforme

I couldn't reproduce this issue in XO-1.75 13.1.0 os22

Note: See TracTickets for help on using tickets.