Opened 3 years ago

Closed 3 years ago

#11379 closed defect (fixed)

PS/2 mouse, keyboard wedged after suspend/resume cycle

Reported by: martin.langhoff Owned by: pgf
Priority: blocker Milestone: 1.75-software
Component: kernel Version: not specified
Keywords: Cc: dilinger, wad, martin.langhoff, wmb@…, carrott
Blocked By: Blocking: #10835
Deployments affected: Action Needed: test in build
Verified: no

Description

With a current build that does s/r -- such as the "C1 stream" os26 -- PS/2 input is dead after the first s/r cycle.

Change History (10)

comment:1 Changed 3 years ago by martin.langhoff

  • Blocking 10835 added

comment:2 Changed 3 years ago by martin.langhoff

  • Priority changed from blocker to high

As of os10 we have a workaround from pgf ("prevent keyboard command traffic after resume").

Leaving open for the root-cause fix, demoting to high.

comment:3 Changed 3 years ago by martin.langhoff

  • Priority changed from high to blocker

The workaround seems to be failing on os12/os13 after a few S/R rounds. Blocker again.

comment:4 Changed 3 years ago by Quozl

  • Blocking 11496 added

(In #11496) Thanks, well known problem, please continue tracking the issue at ticket #11379.

comment:5 Changed 3 years ago by greenfeld

An easy way to almost always wedge the keyboard for me is to let the XO idle suspend, and quickly type a phrase such as "Hello World" to wake it up where the first character is capitalized using the Shift key found below the Ctrl key.

For some reason the other Shift key below Enter doesn't seem to do this.

comment:6 Changed 3 years ago by carrott

  • Cc carrott added

comment:7 Changed 3 years ago by martin.langhoff

  • Action Needed changed from diagnose to test in build
  • Blocking 11496 removed

Should not block #11496 which is purely gfx driver related.

Has anyone hit this with recent builds? OS24/OS25 or later? I am tempted to close as it seems to have gone away for me...

comment:8 Changed 3 years ago by erikos

I did a few times what Sam noted as a testcase (#comment:5) but could not reproduce the wedged keyboard in os25.

comment:9 Changed 3 years ago by Quozl

Test in os26.

comment:10 Changed 3 years ago by martin.langhoff

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.