Opened 3 years ago

Closed 22 months ago

#11474 closed defect (fixed)

save-mfg-data difficulties on XO-1.5

Reported by: dsd Owned by: Quozl
Priority: normal Milestone: 1.5-firmware
Component: ofw - open firmware Version: 1.75/1.5/1.0 Software Build os883 aka 11.3.0
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

In the context of training the Nicaraguan team to do motherboard replacements, we need to transfer manufacturing data from known good laptops to the replacement motherboards. save-mfg-data is presenting some difficulties here.

Reproduced on XO-1.5 with Q3B13 and Q3B23.

Firstly, because it uses disk:\ rather than u:\, the USB disk must be connected before the system is turned on. Using u:\ would be a little nicer for these users.

Secondly, the bigger issue is that it doesnt work, fails with "spi! <-deferred word not initialized" and creates a 0 byte file.

Mitch identified a workaround: flash-open save-mfg-data flash-close

Change History (7)

comment:1 Changed 3 years ago by Quozl

  • Action Needed changed from never set to add to build
  • Milestone changed from Not Triaged to 1.5-firmware
  • Owner changed from wmb@… to Quozl
  • Status changed from new to assigned
  • Version changed from not specified to 1.75/1.5/1.0 Software Build os883 aka 11.3.0

Fixed in svn 2694, save-mfg-data now uses u:\ rather than disk:\, and both save-mfg-data and restore-mfg-data now do flash-open first. Tested on XO-1, XO-1.5, and XO-1.75. Test builds: q2f05jb q3b23jc q4c04ji.

Do you need an XO-1.5 release, Daniel?

comment:2 Changed 3 years ago by dsd

Thanks - no immediate release is necessary.

comment:3 Changed 3 years ago by Quozl

Fixed in Q4C05 for XO-1.75.

comment:4 Changed 3 years ago by Quozl

  • Action Needed changed from add to build to no action
  • Resolution set to fixed
  • Status changed from assigned to closed

Released in Q2F06 and Q3C01.

comment:5 Changed 22 months ago by wad

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still broken on XO-1.5.

Testing with Q3C10, it not only creates a zero length file, it crashes both OFW and the EC. Powering off requires removing both the battery and the DC power.

Neither inserting the key before booting nor using Mitch's work-around have any effect. In all cases it prints:

Creating u:\SHC02602.624
Can't create file
ok

and hangs hard.

comment:6 Changed 22 months ago by Quozl

Works for me. Please test the USB drive and filesystem with Q3C10. In particular, does this command work:

ok to-file u:\SHC02602.624 ." hello world" cr

If it does not, then I'd like an image of the USB drive taken so that I can reproduce and fix.

comment:7 Changed 22 months ago by Quozl

  • Resolution set to fixed
  • Status changed from reopened to closed

This was resolved in IRC as a broken XO-1.5.

Note: See TracTickets for help on using tickets.