Ticket #11487 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

XO-1.75 OS12 backlight is off when you come back inside

Reported by: tonyforster Owned by: pgf
Priority: normal Milestone: 1.75-software
Component: power manager (powerd) Version: Development build as of this date
Keywords: Cc:
Action Needed: reproduce Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Take the XO-1.75 into bright sunlight, sometimes when going back inside the backlight is off. At this stage I have no way to detect when the backlight is turning off so it may be failing to turn back on only sometimes or always.

Change History

Changed 3 years ago by tonyforster

Now using TutleArt to continuously interrogate the light sensor (brightness block) and screen brightness (sensor python block).

Sometimes coming back inside (sensor >>80) the backlight does not come back on

Sometimes going outside (sensor as low as 5) the backlight does not switch off

Changed 3 years ago by Quozl

  • owner set to pgf
  • next_action changed from never set to diagnose
  • component changed from not assigned to power manager (powerd)
  • version changed from not specified to Development build as of this date

Changed 3 years ago by Quozl

  • next_action changed from diagnose to reproduce

Doesn't reproduce here. All six test bed units correctly and reliably turn backlight back on when light level is reduced. Using os12 with kernel 5611fd3.

Tony, please check that the display was not turned off and the laptop not suspended. If the display was off because of lack of keyboard or touchpad action, then it won't turn on just because it gets dark. If the laptop is suspended with the display on, it won't display an updated value.

You might change /etc/powerd/powerd.conf temporarily to prove that:

config_BATTERY_TIME_DIM="1800"
config_BATTERY_TIME_SLEEP="1805"
config_BATTERY_TIME_BLANK="1810"
config_EBOOK_TIME_DIM="1800"
config_EBOOK_TIME_SLEEP="1805"
config_EBOOK_TIME_BLANK="1810"

Tony, please check the EC version, you can find it on the banner display when entering OpenFirmware.

Changed 3 years ago by tonyforster

ofw q4c05 ec 0.3.05

no, the laptop is not asleep,I have keyboard and mouse control

Sorry, I did uncomment two lines in powerd as pgf suggested to get monochrome mode back (see devel list) I cant remember now whether I had this fault before. I'll re comment them.

There is no way to turn off sleep and I am not sure how to edit powerd.conf to do this but it would be good to know how.

Changed 3 years ago by tonyforster

Just recommented the 2 lines and the fault is still there

I would not be surprised if the differences we are seeing are suspend/resume and what is running. I am running TA to continually interrogate the sensor and the screen brightness. That is effectively reads of /sys/devices/platform/dcon/backlight/dcon-bl/actual_brightness and /sys/devices/platform/olpc-ols.0/power_state

Changed 3 years ago by Quozl

While we wait for Sugar to put back the Power icon in the My Settings control panel, you can turn off idle suspend using:

 touch /etc/powerd/flags/inhibit-suspend

This is what Sugar does. No need to be root.

Changed 3 years ago by martin.langhoff

Does this still happen with OS25?

Changed 3 years ago by tonyforster

os25 seems ok

Changed 3 years ago by tonyforster

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.