Ticket #11569 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Browse crashes when viewing large images

Reported by: carrott Owned by: erikos
Priority: normal Milestone: 11.3.1
Component: browse-activity Version: not specified
Keywords: relnote Cc: godiard
Action Needed: communicate Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Visit http://wiki.laptop.org/images/5/5c/XO1.75_B1_mobo_top.jpg observe browse disappears after a number of seconds.

This is probably the same as 11295 which was "fixed" by avoiding large images. It could also be the same issue as 11536.

The following error appears in the log (see attached for the full log):

Gdk-ERROR **: The program 'sugar-activity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 96851 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Terminated by signal 6, pid 1357 data (None, <open file '<fdopen>', mode 'w' at 0xceb5a0>, 'f79541825e9a7736cf6b03e4426de808dbd9c097')

Attachments

org.laptop.WebActivity-1.log (2.8 kB) - added by carrott 3 years ago.
log from session of browse visiting a large image

Change History

Changed 3 years ago by carrott

log from session of browse visiting a large image

Changed 3 years ago by carrott

Forgot to say this is on an XO-1.75 with OS-23.

Changed 3 years ago by martin.langhoff

  • milestone changed from Not Triaged to 11.3.1

We weren't seeing this one, because the milestone was not set.

Changed 2 years ago by manuq

Current WebKit Browse can handle that huge image, tested in os8 XO-1.75.

Changed 2 years ago by martin.langhoff

  • keywords relnote added
  • next_action changed from never set to communicate

After many efforts from Jon Nettleton, we cnnot fix this in the 11.3.1 drivers.

This one gets relnoted for 11.3.1 -- the good news: it is already fixed in 12.1.0 series.

Changed 2 years ago by humitos

  • cc godiard added
  • status changed from new to closed
  • resolution set to fixed

I think we can close this ticket because the problem is fixed in 12.1.0. Please, reopen if you think it's necessary.

Note: See TracTickets for help on using tickets.