Ticket #11581 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

AVC touchpads -- 4F configuration jumpy for some users

Reported by: greenfeld Owned by: martin.langhoff
Priority: blocker Milestone: 1.75-software
Component: olpc-utils Version: Development build as of this date
Keywords: Cc: pgf, tonyforster, carrott, sridhar, jvonau, martin.langhoff
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The new settings loaded to an older AVC touchpad in 11.3.1 os25 via /etc/init.d/olpc-configure are causing a few people (erikos, godiard, etc.) to report odd behavior such as the touchpad starting to refuse to respond. We also have seen occasions where we only could move along the horizontal or vertical axis at any given point in time, turning circular movements into rectangular ones.

Although I personally have just seen the latter on rare occasion in an air-conditioned office something may be wrong with the new settings, or missing. I'm trying to reproduce the issue with a 4F touchpad unit & os25 but have not been able to yet.

Change History

Changed 3 years ago by martin.langhoff

  • cc pgf added
  • owner changed from dsd to martin.langhoff
  • summary changed from New software-loaded settings causing AVC touchpads to misbehave to AVC touchpads -- 4F configuration jumpy for some users
  • component changed from initscripts to olpc-utils
  • priority changed from high to blocker

Changed 3 years ago by tonyforster

  • cc tonyforster added

os25, sugar desktop, AVC trackpad is unresponsive or weakly responsive about 25% of the time

Changed 3 years ago by martin.langhoff

  • next_action changed from diagnose to add to build

yum update will bring down an olpc-utils update with "5F" configuration -- good for all XOs.

On XO-1.75, OS27 will include 5F config, which we need feedback on.

Changed 3 years ago by martin.langhoff

  • cc carrott, sridhar, jvonau, martin.langhoff added

Looping in interested folks.

Changed 3 years ago by martin.langhoff

Changed 3 years ago by martin.langhoff

  • next_action changed from add to build to test in build

Test in OS27

Changed 3 years ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

I think it is safe to close this ticket since no one is complaining about the new settings.

Tested the latest AVC configuration changes over a few days with various AVC revisions, a few Synaptics touchpads (to make sure nothing breaks), ebook mode, all suspend modes, etc. with 11.3.1 os27.

Note: See TracTickets for help on using tickets.