Opened 3 years ago

Closed 2 years ago

#11675 closed defect (fixed)

olpc-configure looks to be writing invalid data to /etc/sysconfig/keyboard

Reported by: jvonau Owned by:
Priority: normal Milestone: 13.1.0
Component: olpc-utils Version: 1.75/1.5/1.0 Software Build os883 aka 11.3.0
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

The keyboard information written to /etc/sysconfig/keyboard appears to be invalid. The resulting /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf looks to be incorrect.(kb.txt). Once you edit /etc/sysconfig/keyboard removing the XKB_ prefix, the resulting 00*.conf file looks to be generated correctly.(kb2.txt) Patch for olpc-utils

Attachments (4)

kb.txt (389 bytes) - added by jvonau 3 years ago.
kb.txt
2kb.txt (366 bytes) - added by jvonau 3 years ago.
2kb.txt
key.diff (504 bytes) - added by jvonau 3 years ago.
key.diff should apply with offsets
build.txt (26.0 KB) - added by jvonau 3 years ago.
"ls /lib/systemd" "uname -a" "rpm -qa"

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by jvonau

kb.txt

Changed 3 years ago by jvonau

2kb.txt

Changed 3 years ago by jvonau

key.diff should apply with offsets

comment:1 Changed 3 years ago by pgf

what specific bug are you seeing? what makes you say the XKB_ prefix shouldn't be there? it's been that way since 2007, so i'm reluctant to change it without understanding the problem you're solving.

comment:2 Changed 3 years ago by pgf

in particular, /usr/bin/olpc-session (also in the olpc-utils package) loads /etc/sysconfig/keyboard, and looks for variables whose names include "XKB_" to use when constructing the setxkbmap command line.

comment:3 Changed 3 years ago by jvonau

I haven't noticed any ill effects either but there is a warning on the initial boot as a result[0] which lead me here. Think the issue is /lib/systemd/system/system-setup-keyboard is calling /usr/bin/system-setup-keyboard and generating the /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf that was attached, while xsetkbmap -query returns the same information either way it is done. If 00-system-setup-keyboard.conf is not needed perhaps system-setup-keyboard should be removed from the build or the functions in olpc_session could be updated to take advantage of system-setup-keyboard.

[0]https://dev.laptop.org.au/attachments/701/2012-03-06%2014.49.17.jpg.

comment:4 follow-up: Changed 3 years ago by pgf

i don't think there's a /lib/systemd in os883. is the OS version listed in this ticket correct?

Changed 3 years ago by jvonau

"ls /lib/systemd" "uname -a" "rpm -qa"

comment:5 in reply to: ↑ 4 Changed 3 years ago by jvonau

Replying to pgf:

i don't think there's a /lib/systemd in os883. is the OS version listed in this ticket correct?

see attached, I just updated powerd and olpc-utils, otherwise this is an stock os883 install on a 1.5.

comment:6 Changed 3 years ago by pgf

my mistake. i'm on the same page now. thanks.

comment:7 Changed 2 years ago by dsd

  • Milestone set to 13.1.0
  • Resolution set to fixed
  • Status changed from new to closed

In 13.1.0 system-setup-keyboard is no longer stripped, and while there was indeed some oddity as identified above, it didn't cause any ill effects.

Note: See TracTickets for help on using tickets.