Opened 3 years ago

Closed 2 years ago

#11738 closed defect (fixed)

Runin discharge battery stat not cleared when XO-1.75s are powered off

Reported by: greenfeld Owned by: Quozl
Priority: low Milestone: 1.75-firmware
Component: ofw - open firmware Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

A few of us were suspicious that XO-1.75s that were powered off were draining their batteries abnormally fast.

Wad reports that "overnight testing seems to indicate that the EC isn't sleeping through the night."

Seen with Q4D05, EC firmware 0.4.02.

Change History (10)

comment:1 follow-up: Changed 3 years ago by rsmith

  • Status changed from new to assigned

The problem is triggered by RUNIN. Enabling runin discharge tells the EC to continually output the battery stats. Stopping runin or rebooting doesn't turn this off.

I'll fix this on the next EC release so that tuning off the laptop makes sure the runin discharge flag is disabled.

comment:2 Changed 3 years ago by rsmith

  • Action Needed changed from diagnose to code
  • Summary changed from EC is not sleeping when XO-1.75s are powered off to Runin discharge battery stat not cleared when XO-1.75s are powered off

comment:3 follow-up: Changed 3 years ago by greenfeld

I am slightly confused, as I have not run any of the affected XO-1.75's in RUNIN for the past few weeks.

Are you modifying the EC to disable battery debug output when powered off, disable the RUNIN discharge test (which does not seem to be the issue as I would have noticed XO's not charging), or both?

I thought those were two separate commands to the EC.

comment:4 in reply to: ↑ 3 Changed 3 years ago by rsmith

Replying to greenfeld:

I am slightly confused, as I have not run any of the affected XO-1.75's in RUNIN for the past few weeks.

Exactly. And unless you have removed the battery without external power connected the EC has been sitting there drawing 6.5mA. It will take 20+ days for the battery to completely run down enough to reset the EC.

Are you modifying the EC to disable battery debug output when powered off, disable the RUNIN discharge test (which does not seem to be the issue as I would have noticed XO's not charging), or both?

I'm changing the EC to make sure the runin discharge flag is cleared if you power the laptop off. Its not possible to be in RUNIN when the laptop is powered off so having it set is invalid. If the EC thinks runin discharge is active then it won't sleep.

I thought those were two separate commands to the EC.

Debug output is orthogonal to going into stop mode. It looks similar because when you turn on the same debugging with 'b3' that command also sets a "no stop mode" flag but that is not the same as the runin discharge flag. There are multiple flags the EC looks at to decide if it can go into stop mode.

comment:5 in reply to: ↑ 1 Changed 3 years ago by Quozl

Replying to rsmith:

The problem is triggered by RUNIN.

This matches my observations. The affected units were in runin and had not had their batteries removed since.

comment:6 follow-up: Changed 2 years ago by greenfeld

This is still present in 12.1.0 os17, even if runin reboots the XO and it is shut down gracefully.

comment:7 in reply to: ↑ 6 Changed 2 years ago by rsmith

  • Action Needed changed from code to package

Replying to greenfeld:

This is still present in 12.1.0 os17, even if runin reboots the XO and it is shut down gracefully.

This is fixed in EC code ver 1.0.00 which I just released. When James comes back on line he can build a new firmware with this release.

comment:8 Changed 2 years ago by Quozl

  • Component changed from embedded controller to ofw - open firmware
  • Owner changed from rsmith to Quozl
  • Status changed from assigned to new

Change made in svn 3211. Will be in next XO-1.75 Open Firmware sustaining release.

(Sorry for the delay, I only just discovered this ticket in bugs@ backlog, wasn't aware of it until now, didn't have my name or component on it.)

comment:9 Changed 2 years ago by Quozl

  • Priority changed from high to low

Won't affect XO-1.75 production, since the main battery is removed before shipping, and RUNIN is not expected to be run after shipping.

comment:10 Changed 2 years ago by Quozl

  • Action Needed changed from package to no action
  • Resolution set to fixed
  • Status changed from new to closed

Is in Q4D25.

Note: See TracTickets for help on using tickets.