Ticket #11745 (closed defect: fixed)

Opened 2 years ago

Last modified 23 months ago

os32 doesn't boot w. serial console, on XO-1.75

Reported by: wad Owned by:
Priority: high Milestone: 11.3.1
Component: kernel Version: Development build as of this date
Keywords: Cc: quozl, greenfeld, martin.langhoff
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I've upgrade a couple of XO-1.75 C1 laptops to 11.3.1_xo1.75-32, and have lost the ability to use the serial console. When I enable the serial console, either using the check key or by editing olpc.fth to set serial-enable to true, the kernel crashes on boot. It prints crash info on the display, but nothing is output on the serial port.

This is easily reproducible.

Change History

Changed 2 years ago by cjb

  • cc quozl, cerlyn added
  • component changed from not assigned to kernel

Can someone upload a photo or video of the failing boot kernel log, please?

Changed 2 years ago by cjb

  • cc greenfeld added; cerlyn removed

Changed 2 years ago by Quozl

  • next_action changed from diagnose to code
  • milestone changed from Not Triaged to 11.3.1

Can be avoided using "false to use-fdt?" before boot.

Per Chris and discussion on #olpc-devel, this patch matches the symptom and appears to be a fix.

Changed 2 years ago by greenfeld

  • cc martin.langhoff added

This patch likely has to be added to -ramp.

Changed 2 years ago by Quozl

  • next_action changed from code to add to build

Pushed.

Changed 23 months ago by martin.langhoff

  • next_action changed from add to build to test in build

Changed 23 months ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

We can boot with the serial console enabled (in verbose mode) or disabled (default) on a XO-1.75 in 11.3.1 os885.

Note: See TracTickets for help on using tickets.