Opened 3 years ago

Closed 3 years ago

#11749 closed defect (fixed)

Touchpad configuration not applied

Reported by: martin.langhoff Owned by: martin.langhoff
Priority: normal Milestone: 12.1.0
Component: olpc-utils Version: not specified
Keywords: Cc: dsd
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

OS 12.1.0 build 5 on XO-1.75 (ramp, AVC touchpad). The touchpad misbehaves as if misconfigured.

Running olpc-fsp-regs verify shows that the registers have not been loaded correctly. olpc-configure has clearly run (~/.olpc-configured exists); rerunning it sets the touchpad registers correctly.

Initial diagnosis: olpc-configure runs too early, racing with psmouse module initialization. We have to break out the touchpad configuration part to scripts triggered from udev.

Change History (3)

comment:1 Changed 3 years ago by dsd

  • Action Needed changed from diagnose to add to build
  • Component changed from distro to olpc-utils

Already fixed in olpc-utils-2.0.5, just waiting for next build.

comment:2 Changed 3 years ago by pbrobinson

  • Action Needed changed from add to build to test in build

in build os6, basic testing it seems better

comment:3 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Running "olpc-fsp-regs verify" on a XO-1.76 with os6 does not result in any output, proving in a UNIX-style that the 6F configuration was loaded.

Note: See TracTickets for help on using tickets.