Ticket #11771 (new defect)

Opened 2 years ago

Last modified 15 months ago

Wikimedia OggPlayer.js does not work on Browse or Firefox

Reported by: peasthope Owned by: humitos
Priority: normal Milestone: Future Release
Component: browse-activity Version: Software Build 12.1.0-21
Keywords: Cc: manuq
Action Needed: reproduce Verified: no
Deployments affected: Blocked By:
Blocking:

Description

This is the same problem as reported in http://bugs.sugarlabs.org/ticket/3320 . I don't know which site is more appropriate for this bug.

Sugar Browse fails to produce sound from vorbis files including http://en.wikipedia.org/wiki/File:Trombone-multiphonics.ogg . Vorbis also doesn't work for Firefox in the Gnome desktop. Sound works in a WAV test and in Twinkle.

Machine 1.5. OS Build 883, 11.3.0. Firmware Q3B22. Sugar 0.94.1. Not visible to me in the version list of the ticket creator.

Happy to consider further investigation.

Regards, ... Peter E., peter at easthope.ca

Change History

  Changed 2 years ago by Quozl

  • next_action changed from never set to reproduce
  • component changed from not assigned to browse-activity
  • summary changed from Failure of Vorbis audio in 11.3.0. to Browse and Firefox do not play ogg files
  • version changed from not specified to 1.75/1.5/1.0 Software Build os883 aka 11.3.0
  • milestone changed from Not Triaged to 12.1.0
  • owner set to erikos

  Changed 2 years ago by Quozl

  • next_action changed from reproduce to diagnose

Tested Browse on os884 on XO-1.75.

Is this what you are talking about? The failure of the Wikimedia OggPlayer Javascript script widget?

  Changed 2 years ago by Quozl

  • summary changed from Browse and Firefox do not play ogg files to Wikimedia OggPlayer.js does not work on Browse or Firefox

Tested Browse on os883 on XO-1.5, same symptoms as with os884 on XO-1.75, except:

  • the play button icon is replaced by a "Play sound" button, which still doesn't work.

In Firefox, the Tools Error Console shows nothing useful about the problem.

  Changed 2 years ago by peasthope

On 11/04/12 03:31 PM, Zarro Boogs per Child wrote:

#11771: Browse and Firefox do not play ogg files Tested Browse on os884 on XO-1.75. * the page does load, and contains an embedded player widget, called OggPlayer.js, which shows a play button,

Yes. I hadn't understood that.

* clicking on the play button on the widget results in the widget changing to a grey X on a grey background,

Yes.

* clicking on the link to the actual file (http://upload.wikimedia.org/wikipedia/en/a/ab/Trombone-multiphonics.ogg) did play the file fine.

Yes.

Is this what you are talking about? The failure of the Wikimedia OggPlayer Javascript script widget?

OK, yes. My description was inadequate. Nevertheless Wikipedia is a useful resource. Seems reasonable to try to make OggPlayer.js work automatically. Is this just a configuration matter? Is there an obstruction from proprietary software?

Thanks, ... Peter E.

follow-up: ↓ 6   Changed 2 years ago by Quozl

Thanks Peter.

I've checked http://en.wikipedia.org/wiki/Wikipedia:Media_help_%28Ogg%29 and we have libtheora, and libgsttheora present in the OLPC OS builds. I've checked http://www.mediawiki.org/wiki/Extension:OggHandler and looked at the change log of the Javascript player, but didn't find anything useful.

I hope one of our expert developers will look into this.

in reply to: ↑ 5   Changed 2 years ago by peasthope

Replying to Quozl:

I've checked http://en.wikipedia.org/wiki/Wikipedia:Media_help_%28Ogg%29 ... didn't find anything useful.

By the way, http://en.wikipedia.org/wiki/One_Laptop_per_Child contains two short videos. Seems reasonable to expect the XO to run each of these properly; stated otherwise, the XO should be able to tell its own story. I'd view this as a critical test for any new release.

In my present test, sound and video are delivered for only a few seconds and then stop. Additional short segments can be obtained by clicking at the pause/play icon but, of course, this should not be necessary.

Best Regards, ... Peter E.

  Changed 2 years ago by Quozl

It is a useful test, and compatibility with a wide range of educational materials is important, but I don't believe this problem is release critical, so I'll keep the ticket priority at normal.

Simon, have you a chance to look at this yet?

  Changed 2 years ago by manuq

  • cc manuq added

  Changed 2 years ago by manuq

Testing first in build os7 for 12.1.0 as I have my machines flashed with it. Works in Epiphany and in Browse for XO-1, XO-1.5 and XO-1.75 . Now I will try build 883 (that is, previous Browse using Gecko).

follow-up: ↓ 11   Changed 2 years ago by Quozl

  • status changed from new to closed
  • resolution set to fixed

I agree, it works in os7 for 12.1.0. It is already fixed. Peter, please upgrade to 12.1.0 once it is released, or you can try the unstable development builds. We won't be releasing a fix for 11.3.x.

in reply to: ↑ 10   Changed 19 months ago by peasthope

Replying to Quozl:

I agree, it works in os7 for 12.1.0. It is already fixed. Peter, please upgrade to 12.1.0 once it is released, or you can try the unstable development builds.

12.1.0 is now installed on the XO-1.5. Yes, OggPlayer.js works for Epiphany. The movies in Wikipedia work with tolerable small delays. Thanks, Peter E.

  Changed 19 months ago by peasthope

  • status changed from closed to reopened
  • resolution deleted

I spoke too soon. A movie begins correctly but does not finish. Have Epiphany open http://en.wikipedia.org/wiki/One_Laptop_per_Child and start the introductory video below the infobox. On this XO-1.5 with 12.1.0 the movie plays up to the explanation of the fourth of "The 5 Principles". There it freezes. To recover I close Epiphany with a click in the x button in the upper right corner.

Does the video stop when a buffer is filled? Sorry, but I haven't studied OggPlayer.js.

Regards, .,. Peter E.

  Changed 19 months ago by Quozl

  • next_action changed from diagnose to reproduce
  • version changed from 1.75/1.5/1.0 Software Build os883 aka 11.3.0 to Software Build 12.1.0-21
  • milestone changed from 12.1.0 to 13.1.0

Thanks. Perhaps OggPlayer.js (provided by Wikimedia Foundation) has changed again, breaking it on 12.1.0. If so this might be escalated to Wikimedia. It needs further investigation, so I've brought it into the current development milestone for attention.

follow-up: ↓ 15   Changed 19 months ago by dsd

  • milestone changed from 13.1.0 to Future Release

Pushing out for now - with our current workload I don't see how to fit it into 13.1.0 scope. Even if we solve this bug, unfortunately it will not be a very good experience because we only get accelerated video playback via <embed> or <object> tags, not <video> which now happens to half-work more by coincidence than anything else.

in reply to: ↑ 14   Changed 19 months ago by peasthope

Replying to dsd:

Pushing out for now - with our current workload I don't see how to fit it into 13.1.0 scope.

Ok; thanks for the reply, ... Peter E.

  Changed 15 months ago by humitos

  • owner changed from erikos to humitos
  • status changed from reopened to new
Note: See TracTickets for help on using tickets.