Opened 3 years ago

Closed 2 years ago

#11782 closed defect (fixed)

Sometimes two icons are shown in the frame for the network

Reported by: manuq Owned by: erikos
Priority: normal Milestone: 12.1.0
Component: sugar Version: 1.5-C2
Keywords: Cc: dsd
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

This is in the same machine with the issue in ticket #11778 . If I keep typing or moving the cursor, the machine doesn't fall in #11778 and keeps connected, but sometimes two icons appear:

Picture:

http://dev.laptop.org/~manuq/net-icon-twice.png

Attachments (1)

shell.log (4.7 KB) - added by manuq 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by dsd

Please capture sugar logs from when this happens.

comment:2 Changed 3 years ago by dsd

  • Component changed from not assigned to sugar

comment:3 Changed 3 years ago by dsd

  • Action Needed changed from never set to review
  • Cc dsd added

I had seen this as well, and I managed to reproduce it. If you wait approxiamtely 5 seconds at the naming screen before continuing you will see it - the network driver finishes loading right when Sugar is loading up. (its taking a long time due to #11710)

Diagnosed and sent a patch to fix this:

[PATCH] Prevent handling network devices twice (OLPC#11782)

comment:4 Changed 3 years ago by manuq

Just for the record, seems that Daniel has a fix!

I got what seems another flavour of the same issue?

http://dev.laptop.org/~manuq/net-icon-twice2.png

One icon that shows no wireless network and the other that is connected. Log of Sugar attached.

Changed 3 years ago by manuq

comment:5 Changed 3 years ago by dsd

  • Action Needed changed from review to add to build

Fixed in sugar-0.95.7

comment:6 Changed 3 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 12.1.0 build 8.

comment:7 Changed 3 years ago by manuq

Tested XO-1.5 and XO-1, no more twin network icons, great.

comment:8 Changed 2 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

I could not reproduce this issue with 12.1.0 build 8, so I presume it is fixed.

Note: See TracTickets for help on using tickets.