Opened 3 years ago

Closed 2 years ago

#11823 closed defect (fixed)

XO-1.5 firmware build times are a month behind

Reported by: Quozl Owned by: wmb@…
Priority: low Milestone: 1.5-firmware
Component: ofw - open firmware Version: Development firmware
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Seen on Q3C05 and some other builds, the .built word displays a value that is one month behind the system time of the build virtual host "firmware".

builton.fth also has the incorrect month.

Can be reproduced using the wrapper as follows:

quozl@firmware:~/q3/openfirmware$ cpu/x86/Linux/forth cpu/x86/build/basefw.dic -s 'today .s cr bye'
30 3 2012 
quozl@firmware:~/q3/openfirmware$ date
Mon Apr 30 04:31:09 EDT 2012
quozl@firmware:~/q3/openfirmware$ 

Change History (6)

comment:1 Changed 3 years ago by wmb@…

  • Action Needed changed from never set to add to build

svn 2958 - sys-time&date was returning the wrong month. OFW represents month numbers as 1..12, consistent with human usage, while POSIX localtime() represents them as 0..11, more convenient for indexing into C arrays.

comment:2 Changed 3 years ago by Quozl

  • Action Needed changed from add to build to code

svn 2961 has another fix to sys-time&date, but the symptom persisted because builder.dic in repository needs update.

Updated builder.dic in svn 2962, but now kernel.dic cannot be rebuilt, because svn 2899 removed [""] which was in use by cpu/*/fixvoc.fth

Need some guidance please.

comment:3 Changed 3 years ago by wmb@…

<   [""] <vocabulary>  also symbols  find   previous  ( acf true | str false )
>    " <vocabulary>"  also symbols  $find   previous  ( acf true | adr len false )

comment:4 Changed 3 years ago by Quozl

  • Action Needed changed from code to package

Thanks. Fixed as of svn 2967.

comment:5 Changed 3 years ago by Quozl

  • Action Needed changed from package to add to build

comment:6 Changed 2 years ago by Quozl

  • Action Needed changed from add to build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Is in Q3C06.

Note: See TracTickets for help on using tickets.