Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#11846 closed defect (fixed)

Firmware q2f10: Hardware Test : Audio: low volume

Reported by: earias Owned by: Quozl
Priority: high Milestone:
Component: ofw - open firmware Version: Development firmware
Keywords: Cc: reuben, wmb@…
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

The volume of audio test is more lower than older versions

Change History (13)

comment:1 Changed 3 years ago by Quozl

  • Action Needed changed from never set to reproduce
  • Component changed from not assigned to ofw - open firmware
  • Milestone Not Triaged deleted
  • Owner changed from quozl@… to Quozl
  • Status changed from new to assigned
  • Version changed from not specified to Development firmware

Thank you for your problem report.

I have tested Q2F10 and Q2E48 with volume control set to maximum, using a sound level meter at 5mm distance. Both versions produced 81.2 dBA for the sound command (the startup sound), and 68.1 dBA for test /audio sweep.

Please advise your method of measurement, measurement results, firmware versions, and volume level?

comment:2 Changed 3 years ago by earias

Q2E45

comment:3 Changed 3 years ago by Quozl

  • Action Needed changed from reproduce to no action

Thanks.

I've tested Q2E45 against Q2E48, and the older version yields 82 dBA during test /audio. This is a 14 dBA drop for the Open Firmware audio test only. It does not affect the startup sound, Linux or Sugar.

I've briefly checked for the changes between Q2E45 and Q2E48 that may have caused the lower volume. This period covers development of manufacturing tests for XO-1.5 hardware, and changes to shared code. During these changes there were refinements to the method used for producing sine waves, but no change to the volume settings.

XO-1 is no longer in mass production, so the manufacturing test for audio is not required by OLPC. That leaves use by deployments.

I propose that:

  • those using test /audio on XO-1 be taught that the test is less loud after Q2E45, and that this change has no effect and no impact,
  • this ticket be closed.

Please respond. In particular I'm interested in why you consider this to be high priority. I must be ignorant of something.

comment:4 Changed 3 years ago by earias

ok consider for future versions

comment:5 Changed 3 years ago by Quozl

  • Resolution set to fixed
  • Status changed from assigned to closed

No, we will not consider fixing this for future versions given the information available so far. There is no impact. I shall close the ticket. Thanks for your bug report.

comment:6 Changed 2 years ago by reuben

  • Cc reuben added
  • Resolution fixed deleted
  • Status changed from closed to reopened

This should be corrected in future versions of all hardware versions. This is both a mfg test and field testing mechanism.

comment:7 Changed 2 years ago by reuben

  • Cc wmb added

Test using q2e41.
Test using q2f11.

There is significant difference in output volume and perhaps even a different sweep being played. This is a regression and should be reverted to the settings used in q2e41.

comment:8 Changed 2 years ago by reuben

Any progress here?

comment:9 Changed 2 years ago by Quozl

  • Action Needed changed from no action to test in build
  • Cc wmb@… added; wmb removed

Please test http://dev.laptop.org/~quozl/q2f11je.rom

The calculation of the amplitude of the sine wave was using a single length 32-bit intermediate result, which overflows.

Affects XO-1 and XO-1.5 only. Doesn't affect XO-1.75.

Fixed in svn 2994.

The regression was introduced in svn 2260, source file isin.fth, the last line of set-period which calculates fstep. Changing this code back to what it was before svn 2260 fixes the symptom, but there is a loss of precision due to the order of operations.

(On XO-1 and XO-1.5, the */ operator is converted to >r * r> / by the FCode tokeniser. The */ operator is left as is on XO-1.75 because the audio test is not FCode tokenised, so the intermediate result is a double length 64-bit value. Mitch, perhaps the tokeniser needs a fix?)

comment:10 Changed 2 years ago by reuben

Tested okay by earias.

comment:11 Changed 2 years ago by Quozl

  • Action Needed changed from test in build to add to release

Thanks. Review changes by Mitch also made. Will be in Q2F12.

comment:12 Changed 2 years ago by Quozl

  • Action Needed changed from add to release to no action
  • Resolution set to fixed
  • Status changed from reopened to closed

Is in Q2F12.

comment:13 Changed 2 years ago by Quozl

Is in Q3C07.

Note: See TracTickets for help on using tickets.