Opened 2 years ago

Closed 2 years ago

#11858 closed defect (fixed)

Mesh networking broken in 12.1.0

Reported by: greenfeld Owned by: dsd
Priority: high Milestone: 12.1.0
Component: network manager Version: Development build as of this date
Keywords: Cc: pbrobinson
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

XO-1 mesh networking is broken in 12.1.0 os9.

The Mesh network connects and assigns itself an IP address on "Channel 0" but two XO-1's on this channel do not talk to each other.

Attempting to manually select a Mesh network channel in the Neighborhood view fails.

Change History (7)

comment:1 Changed 2 years ago by dsd

  • Milestone changed from Not Triaged to 12.1.0

comment:3 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to package

Patch accepted upstream.

comment:4 Changed 2 years ago by dsd

  • Action Needed changed from package to add to build
  • Cc pbrobinson added

comment:5 Changed 2 years ago by pbrobinson

should be included in the NM git snapshot in F-17 "0.9.4.0-9.git20120521"

comment:6 Changed 2 years ago by pbrobinson

  • Action Needed changed from add to build to test in build

in os12

comment:7 Changed 2 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from assigned to closed

Mesh networking support is present in 12.1.0 os12.

Upon resuming a XO-1 from lid close/power-off suspend we start rescanning networks again (including mesh channels) to find one to join. I do not know if this desired for mesh XO-1s which are relaying.

I also do not know how I could check if mesh networking is active and relaying while the XO is suspended.

Note: See TracTickets for help on using tickets.