Ticket #11902 (closed defect: fixed)

Opened 23 months ago

Last modified 22 months ago

ALPS support broken in OFW diagnostic menu

Reported by: greenfeld Owned by: Quozl
Priority: normal Milestone: Not Triaged
Component: ofw - open firmware Version: Development build as of this date
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

In Q2F11/11.3.1 os885, using an ALPS touchpad on a XO-1 to move the mouse around the menu screen does not work. The cursor just erratically moves staying in the lower-left corner of the screen.

Using a Synaptics touchpad-equipped XO-1 works with this menu.

The mouse test in OFW still works with the ALPS touchpad.

Change History

Changed 23 months ago by wmb@…

  • owner changed from wmb@… to Quozl
  • next_action changed from diagnose to test in build

Fixed by svn 2989. Test build at http://dev.laptop.org/~wmb/q2f11ma.rom .

Changed 23 months ago by Quozl

  • status changed from new to assigned
  • next_action changed from test in build to add to build

Tested, works fine with ALPS and Synaptics touchpad on XO-1, to be included in next release.

Changed 23 months ago by greenfeld

Do we need a separate ticket to fix this for XO-1.5 and XO-1.75 (should ALPS ever start working on the latter)?

This issue was reproduced on a XO-1.5 with ALPS with Q3C06.

Changed 23 months ago by Quozl

The changed source file in svn 2989 is used in both the XO-1 and XO-1.5 builds. Here is an XO-1.5 build for you to try: http://dev.laptop.org/~quozl/q3c06jc.rom

The same file is not used in the XO-1.75 build, and I've no memory of ALPS support being done for XO-1.75.

Changed 23 months ago by Quozl

  • next_action changed from add to build to add to release

Changed 22 months ago by Quozl

  • status changed from assigned to closed
  • next_action changed from add to release to no action
  • resolution set to fixed

Is in Q2F12.

Changed 22 months ago by Quozl

Is in Q3C07.

Note: See TracTickets for help on using tickets.