Opened 2 years ago

Closed 2 years ago

#11929 closed defect (fixed)

Remove empathy, it now requires OpenGL

Reported by: greenfeld Owned by: pbrobinson
Priority: high Milestone: 12.1.0
Component: distro Version: Development build as of this date
Keywords: Cc: dsd
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

If #11810 cannot be fixed or worked around, then we need to remove applications from the builds which do not work.

One example program that currently does not work (and is believed to be due to clutter) is Empathy.

Change History (8)

comment:1 Changed 2 years ago by dsd

That's the first I've heard of empathy breakage. Can you elaborate on the problems?
What other shipped apps are affected?

comment:2 Changed 2 years ago by greenfeld

Empathy simply dies on startup with a Segmentation fault before it even shows a window. If started from the GNOME launcher instead of a Terminal, the busy startup notice appears but eventually times out with no error message.

According to RPM, the packages that depend on libclutter-gst-1.0.so.0 appear to be cheese-libs, empathy, totem, and totem-mozplugin. Totem is likely used by the web browsers; I'm not certain who uses cheese-libs.

comment:3 Changed 2 years ago by pbrobinson

In fallback mode it shouldn't use clutter code paths even if its built in. The fallback seems to work OK with totem. Any chance of a RHBZ bug with a backtrace?

comment:4 Changed 2 years ago by greenfeld

I'm not sure what is quite going on here yet.

  • If just run as "empathy" from the GNOME Terminal as started by the olpc user, it segfaults.
  • If I run "su -" to root, optionally edit the ulimit for cores, and then "su - olpc" back to run empathy, I see "(empathy:3819): empathy-CRITICAL : main: assertion `gtk_clutter_init (&argc, &argv) == CLUTTER_INIT_SUCCESS' failed"
  • If I "su -" to root, "su olpc" back (not setting environment) and run empathy, we segfault.

I set the ulimit the last way and obtained a core file, but why we are segfaulting in some environments but not the other probably should be determined before complaining upstream.

comment:5 Changed 2 years ago by dsd

  • Cc dsd added

comment:6 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build
  • Summary changed from Remove programs dependant on Clutter/COGL from build if they cannot be fixed to Remove empathy, it now requires OpenGL

Confirmed that empathy fails on startup due to not being able to initialise clutter. I looked at the source code, and confirmed that it calls into clutter early on and fails app startup if clutter isn't happy.

Maybe this could be improved in future: https://bugzilla.gnome.org/show_bug.cgi?id=678343

For now, as agreed in the 12.1.0 meeting, we will drop empathy from the build. If this is missed by a deployment, we encourage pidgin to be considered as a replacement.

Another option would be to recompile empathy without video call support. This would likely avoid the problem. We aren't in the business of maintaining our own packages in this way, but we could possibly do it on-demand if it would help a deployment.

comment:7 Changed 2 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 12.1.0 build 15.

comment:8 Changed 2 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Empathy has been removed in 12.1.0 os15.

Note: See TracTickets for help on using tickets.