Opened 2 years ago

Closed 2 years ago

#11952 closed defect (fixed)

XO-1.75 os14 manifest fail on subsequent run

Reported by: Quozl Owned by: dsd
Priority: high Milestone: 12.1.0
Component: not assigned Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

if the TS tag is set to RUNIN, and the first 24-hour loop of runin passes, the subsequent will fail with a manifest error identifying wtmp as having changed.

however, there had been no human login attempt, not even a debug shell.

regression over 11.3.1.

breaks documented usage.

Check fs version 14 with hash f4791264eacd95c8537b70e4db9b2b31ffe39f3f8364b5339c3a3f46b9eda182
Loop 000000 : Contents manifest failure at line 319
Last file examined: wtmp
FAIL: fscheck: 1339971263 : 1694.35 : code=1
Loop 000001 : 

Change History (8)

comment:1 Changed 2 years ago by dsd

  • Owner set to dsd

comment:2 Changed 2 years ago by Quozl

As far as I can tell, this problem does not break use of release in mass production ... because an fs-update would be done before a repeated runin. But I have asked.

comment:3 Changed 2 years ago by dsd

It could also suggest other problems, so I'll treat this with high priority and hopefully look at it soon. Thanks for reporting.

comment:4 Changed 2 years ago by Quozl

  • Priority changed from normal to high

Factory has replied. Has moderate mass production impact. Test operator is given opportunity to re-run RUNIN by factory scripting. fs-update is a significant time cost.

comment:5 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build

Fixed in olpc-os-builder da79b55. This was a race condition that was always happening, but seemed to be hit by runin every time.

comment:6 Changed 2 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 12.1.0 build 16.

comment:7 Changed 2 years ago by Quozl

Seems to work fine on XO-1.5, also restores our ability to re-run runin despite having logged in to Sugar ... which was something we lost along the way without recognising this race as the cause.

comment:8 Changed 2 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for testing.

Note: See TracTickets for help on using tickets.