Opened 2 years ago

Closed 19 months ago

#11979 closed defect (fixed)

Fix geode all-black composite issue

Reported by: dsd Owned by: jnettlet
Priority: normal Milestone: 13.2.0
Component: x window system Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

In #11860 we worked around a geode bug for 12.1.0, where the GNOME notification area icons get rendered black. This is https://bugs.freedesktop.org/show_bug.cgi?id=51360

Going forward we need a real fix, or we need upstream to accept the workaround.

Mart (upstream developer) expressed interest in having a look but hasn't had a chance yet.

Change History (5)

comment:1 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build

comment:2 Changed 2 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 13.1.0 build 14.

comment:3 Changed 22 months ago by greenfeld

  • Action Needed changed from test in build to diagnose
  • Version changed from not specified to Development build as of this date

The wireless tray icon does not appear and is rendered black in 13.1.0 os24.

It is however clickable and the dropdown box appears to select a network.

comment:4 Changed 22 months ago by greenfeld

Seen on XO-1 with xorg-x11-drv-geode-2.11.14-1.fc18.i686

comment:5 Changed 19 months ago by dsd

  • Milestone changed from 13.1.0 to 13.2.0
  • Resolution set to fixed
  • Status changed from new to closed

The battery and network icons can be seen in GNOME in 13.2.0 build 6 for XO-1.

Note: See TracTickets for help on using tickets.