Opened 2 years ago

Closed 2 years ago

#11998 closed defect (fixed)

q4d19 prevents linux boot

Reported by: Quozl Owned by: wmb@…
Priority: normal Milestone: Not Triaged
Component: ofw - open firmware Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Does not occur with Q4D18.
Does occur with Q4D19.

[    4.392318] Kernel panic - not syncing: Attempted to kill init!
[    4.404624] [<c0036ce8>] (unwind_backtrace+0x0/0x11c) from [<c0399f28>] (panic+0x68/0x188)
[    4.419381] [<c0399f28>] (panic+0x68/0x188) from [<c004ce10>] (do_exit+0xa0/0x6cc)
[    4.433433] [<c004ce10>] (do_exit+0xa0/0x6cc) from [<c004d6a8>] (do_group_exit+0x0/0xec)
[    4.448029] [<c004d6a8>] (do_group_exit+0x0/0xec) from [<c0031280>] (ret_fast_syscall+0x0/0x30)

Change History (3)

comment:1 Changed 2 years ago by wmb@…

  • Action Needed changed from never set to add to build

The problem is twofold: Firstly, the change that moved the device tree away from 0x100 caused it to collide with the initrd. Secondly, the rearrangement of the SDHCI node structure kept the kernel from finding the root device.

Fixed by svn 3040 and 3041.

comment:2 Changed 2 years ago by Quozl

  • Action Needed changed from add to build to no action

Is in Q4D20, and works.

comment:3 Changed 2 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.