Opened 2 years ago

Closed 22 months ago

#12044 closed defect (fixed)

XO-1 glyph rendering bugs in X

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 13.1.0
Component: x window system Version: not specified
Keywords: Cc: jnettlet
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Open the Sugar terminal activity and get a good amount of text on screen.

Press F1,F4,F1,F4,... to change between the network view and the terminal. After a few switches, some of the text in the terminal can't be read.

Need to take a screenshot and file an upstream bug.

Attachments (1)

0001-Accelerate-compositing-of-solid-pictures.patch (5.1 KB) - added by dsd 2 years ago.
chrome driver patch

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by dsd

  • Summary changed from XO-1 graphics rendering bugs in X to XO-1 glyph rendering bugs in X

This is probably https://bugs.freedesktop.org/show_bug.cgi?id=47266

We are likely to see it in the chrome driver too, when that becomes ready.

Needs an X server fix for the unaccelerated path being hit, a new accelerated path added to the drivers, or ideally, both.

comment:2 Changed 2 years ago by dsd

  • Cc jnettlet added

Saw the same type of text corruption on the chrome driver on XO-1.5 (13.1.0 build 2).

comment:3 Changed 2 years ago by dsd

At least at this moment, an easy way to reproduce it there is to open gnome-terminal, maximize it, do something to fill the screen with text.

Then open the applications menu and go down the subcategories one-by-one. Screwed up text will appear either in the menus, or in the terminal behind.

Changed 2 years ago by dsd

chrome driver patch

comment:4 Changed 2 years ago by dsd

Jon, I have attached a chrome driver patch to implement accelerated compositing of solid pictures. This fixes the text rendering problems that were coming up frequently when using the GNOME menu.

comment:5 Changed 2 years ago by dsd

xf86-video-geode commit a46486b05f4674fc17f36947c97bc281c1d00d26 solves this, I've tested it. If it doesn't fall into a release soon I'll patch it into Fedora myself.

comment:6 Changed 2 years ago by dsd

  • Action Needed changed from diagnose to add to build

XO-1.5 fixed in xorg-x11-drv-chrome-5.74.33-13 and sent a mail to the openchrome list.

XO-1 fixed in xorg-x11-drv-geode-2.11.13-4.fc18

The X server bug may also be fixed upstream for the unaccelerated case too.

comment:7 Changed 2 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 13.1.0 build 9.

comment:8 Changed 22 months ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

I could not reproduce this in 13.1.0 os27.

Note: See TracTickets for help on using tickets.